Plex App - anyone got it working?


Anyone successfully got the Plex App working?

*First, find the plex unique address that looks something like this ( You can find that by launching the plex app via Look in your browser developer console for the plex-server you are looking for. It should near the top prefixed with [Connections]. Use this address for the address you are connecting to plex with, not your local plex ip. Reason being, https certificates needs to be trusted. Then finally, enable https on your plex connection in Homey :)*

Got all the above done - ok but stumped by how do I ‘enable https on your plex connection in Homey’

Not too sure what/how to do that.


Yes, I also followed the instructions but I am not able to work.

Currently I have it like that.

Can you @Swifty help us?

clueless, pls share a flow!

That “direct” domain in the address only works if your router does not do “DNS rebind protection” or has whitelisted for dns rebind. So maybe that is your issue as the app works fine for me. But I have whitelisted in my router.

If you are victim to DNS REbind protection, Homey cannot reach the plex server using that address.

Hi @Shakesbeard

I think my router does not have DNS rebind protection.

The “direct domain” I have put it that way because it indicates the developer, that for the correct operation it must be configured like this.

Do you have it with another domain?

Hi @Tangodelta

I attached the flow.

Grateful for the help !!!

The app also works if you use the local IP of your plex server instead. Given it has a static IP it should work as fine.

Hi @Shakesbeard

I tried it at the first moment of installation and it didn’t work.

Then I read the developer documentation and said it worked with the domain

I’m going to try it this afternoon and I will tell you shortly about the test result.

Thank you!!!

Just add local IP address on first line and port on second

When i try to use paused, i cant add my player, testing gives a red mark on the flow. could someone help me?