Please help wit my new Philips TV

Hi there,

I have bought a new philips tv and have installed the Philips TV app on homey.

I wan’t to make flows like : If ‘‘time’’ then ‘‘put the source to…’’ and ‘‘switch to channel’’. In de card I can select my philips tv but if I wan’t to select the input source it stays empty. It show me a link to the appstore of homey to the philips tv app. The same thing happens whens I wan’t to make a flow to switch to a channel.

Is there anything I am doing wrong? please help.

Can you post a screenshot of the problem?

Hi Dabon,

Here you are. As you can see, I can select my tv but after that when I want to enter a channel it doesn’t works.

Hope that you can help me.


Have you tried deleting your TV from homey and adding it back in? Or restarting your homey.

I tought this wasn’t possible anymore on newer tv’s?


Just did it, still the same problem.

See this picture with an other card, in this flow it seems to work but nothing happens on my tv, so the checkmark is false.

Maybe a setting on my Philips tv?? I just checked al the options and can’t find anything .

Which one of the apps are you using?

I see one of them is IR and the other one seems to be some other solution.

I am using

Okey, I see the app hasn’t been updated for a long time. And if your TV is brand new, Its likely its not fully supported, so that would be my best guess.

But, if you have homey near the TV or an IR extender, you could use the other app, which I bet works better.

HI Wjay, check Philips TV > 2016 support

I expect that the “old” jointspace protocol wil not working with the a new philips TV.

Thanks Mickel_Luiten and Dabon.

That sucks, I am not happy with this. The first thing I do when I (wan’t to) buy new electronic stuff is checking in the homey app store for an app for the thing I am buying. I didn’t do research to models and types and old or new versions etc.
It is a lesson for now.