NVIDIA Shield TV when TV is set to ON

Hello everyone,

I hope someone can help me out and maybe it is not possible (yet) but who knows. I have a Samsung TV connected to NVIDIA Shield TV. Setting my TV on in any flow does work perfectly but my NVIDIA Shield TV doesn’t get a signal to awake out of sleep mode. I watch TV through my NVIDIA Shield TV so would be nice to have the possibility.
Probably you all know that NVIDIA Shield TV runs on Android TV. So I hope that someone knows a way how I can send a signal to NVIDIA Shield TV to get ON when TV is set to ON.

I know a similar question is been asked somewhere in 2019 but I hope there is a way now in 2021.

Hope someone has a trick how to fix this.

EDIT: The ideas below are only possible if you have a Homey Pro for now… sorry
.
.
.

Shot in the dark, but, isn’t it discovered by adding it as a Chromecast device?

And, the Kodi app can be of use:

Hello,

using CEC doen’t ok for you ?
(that what I use to wake up Shield via TV and now with Homey Bridge).

Br,

Hi Miron,

The only way I have it work now is that I have to use the NVidia remote control to put everything on. So when I push the ON button of NVidia my Samsung tv and Samsung soundbar switch on. I would love to know how I can put the NVidia on when my Samsung tv goes on. So if you know a way how to do that I would appreciate it.

Regards,

Hello,

you have to setup the CEC (or anynet+ on samsung) parameter to On, both on TV and Shield.

Br,

Miron,

This is all setup and only works one direction. So when I power on Nvidia shield my tv and soundbar automaticly turns on. The problem is i cannot add nvidia shield into the homey bridge. When I turn on my tv my soundbar turns on automatically but my nvidia shield is not turned on. So I was hoping someone in here has a working solution because i can control my tv in homey bridge.

Regards,

Unfortunately the Bridge does not & cannot interact with your local (wifi) network.
It could work if there’s an Nvidia cloud API based app.

These are all on and still doesn’t work? Then you should try to fully reset your shield

Yeah, check your hdmi cec settings on the tv and shield. It should turn on automatically when your tv turns on. I didn’t need to use homey to create an automation for that. The hdmi cec handled it.

Sorry, this is a story with not Android Samsung, so may be totally useless noise…

On Samsung TV-s i use is a initial setup option “watch TV from digibox” (or something like that - where You choose the input source, one of Antenna/Cable/Box). And yes, have noticed, but not deep-digged(with Logitech Harmony do not have need ) - the Anynet/CEC settings may not work, when in initial setup was given source as “Not The Box”. But when the “TV source” is defined as a set-top-box, then at least TV is asking “seems, Your box is not switched on - do switch it on now?” and givin’ possibility to “press virtual power button”

Another idea: What’s the actual state of NVIDIA? May-be it already switched on by means of CEC and just sleeping ( black/blank screensaver)? Then no power button needed, but some other button via HDMI-CEC. For example an “UP” or “VolUP” - if forwardable.

Peter,

This has nothing todo with local network and I am aware that local network is not supported by Homey bridge.

Radon,

I have checked all the settings and as your screenshot shows all these settings are enabled on my Nvidia Shield. Also on my Samsung tv is HDMI Anynet enabled.

Cuprum,

What you are saying here sounds interesting and I will have to find the setting that your are mentioning here. Can you tell me where I could find this option? When I try to start TV from samsung rc or with Homey it will ask me if the tv should try to power on the device for tv (virtually). When I say yes to that option it will not be turned on. So I think that my Samsung TV is not aware what kinda device is responsible for showing tv image.

For the other idea I do not turn the nvidia shield off but put it in sleep mode but will try what you are saying and use the ok button or volume up button and see if it comes out of sleep mode or not.

Actually - this is not an standard option. As i already told (may-be not so clearly) - this option is not visible in ordinary settings menu. Only for initial set-up (fortunately initial setup is possible to initiate from menu; unfortunately it resets virtually all settings).

Right, I know it’s about CEC and stuff, but somehow I got the impression you wanted to connect Homey with … bla.
I hope you’ll find a fix!

Hi Cuprum,

So what you are saying is that i need to reset my samsung tv so I get to the initial setup and can then maybe setup the power order in the right way. I think I will do that and try to see if that works out. Will let it know in this thread.