Logic card does not work properly

The logic card normally contains two fields to fill in.
This time the card contains two squiggles in the right field and when entering the number a second field remains on the right. When filling in the left field, the Homey crashes. This can be seen in the picture

Normally I can enter a number on the right which is used as the value for the calculation.

Can’t reproduce it:

(macOS Version 14.4, Opera One (Version: 108.0.5067.29))

You can try:
– Refresh website
– Close, open browser
– Log out, log in
– Delete cookies
– Try an other browser

Does the same happend if you connect the 2 flow cards…? In your picture they are not connected

1 Like

It’s about this card from the Logic selection


It looks like this in the flow


but in the picture above it looks different, it contains two fields on the right

its different to normaly


They are the same, its just that you have selected/clicked on 1 of the cards… it will then display the two fields on the right…and one in field.

Edit: Just noticed what you ment, that is strange… i’m sorry, i am lost.

I’ll try again to describe the problem more clearly. First of all, I’m helping a friend who also bought a Homey create his first flow.
When I click on the card from the logic app number is greater than number on my computer I get a version that contains two fields and looks like the first picture. The name of the numerical variable comes in on the left and the number 90 on the right
If he clicks on the same card on his computer he gets
he another card in his flow. It contains two fields on the right.
If he then uses the Battery variable on the left and the number 90 on the right, the computer crashes. This error message then appears

I do understand the problem. It’s of course not correct there are 2 number fields on the right side and Homey crashes.
But I just wondering if you have already tried our advice? You don’t mention anything about this. And the screenshot clearly shows also what you have to do.

This is a user forum only. If it’s a serious Homey problem, then probably no one in this forum can help you, so please contact Athom support.

1 Like

The question has been going on for a while and support may respond.

Well, I thought support probably wouldn’t be open over the weekend and the answer might arrive next week.

Since I have found very clever people in the forum so far, I wanted to ask the question here too.

The way it looks for me it might be because I use Linux and an Opera browser, my friend uses a Mac and Macs are just a bit strange sometimes.

The problem is solved. The browser on the MAC was the cause

1 Like

+1 for sharing the issue / fix.

That goes without saying. !! If such a rare problem occurs, someone else might be happy to hear the tip.
Problems often arise outside of Homey and it would be unfair
always blaming it on Homey. I have come to really appreciate the Homey, it is an extremely helpful device.

1 Like

Sorry @wolfgang_linke, but you haven’t told us the solution.
Which macOS/browser combination caused the problem?
Which macOS/browser combination is now working properly?

Btw, In my first post I suggested already to test a different browser… :man_shrugging:t3:

I asked my friend
He says Google Chrome on Mac doesn’t work. The original Mac browser Safari works well.
Opera Browser runs very well for me under Linux.
I hope this helps.

Many thanks to the moderators

1 Like

You can inform your friend that the Opera browser also works very well with a Mac, in my opinion even better than the Safari browser.