ITEAD Sonoff

Well, I have also tried to send some “feedback” to Athom directly, perhaps it is some bug or issue with my Homey device. E.q. when I run a manual flow test with output to Timeline , then the manually added code is not shown (when using Android’s app) and it is shown when using PC based GUI…

I am using also this app, but as far as I remember, then the RF Bridge is not (yet) supported…

Athom made some changes to SDKv2 that broke the Sonoff app, I created a workaround. You can install a test version of the app from here: Sonoff | Homey

Let me know if that solves your problems, if so I will do a proper release.

Thank You for the super-fast response. The test-version works nicely and and RF Bridge’s code-words are working again !! I have also a ticket open with Support - shall I notify them that You have found the solution?

My guess is that support will refer back to me anyway, as they tend to do :wink:

It’s now been released as stable.

Have you seen this Kickstarter project, a s art scene wall display for 47€? Would it work in potential with Homey?

In potential: yes. Someone just has to make an app for it :wink:

1 Like

I’ve recently seen this on YouTube… Looks interesting if it’s hackable.

I’ve also seen a similar touch screen product made by Brilliant which has already been hacked and can be customised… Takes some work though…

Hi! I am quite new to this community and today I have tried flashing sonoff basic for the first time with tasmota. I managed to do that, I think I configured everything as it should be and I can switch the sonoff on and off through Homey. The problem is that the sonoff basic I have, has a temperature sensor connected to it. I used tasmota sensors build when flashing and I can see the temperature through a web interface.
Is there a way to add my sonoff to Homey and to be able to read the temperature? I tried adding it as Sonoff basic and as Sonoff TH10 (which it is not) but it did not work. It only works if I add it as Generic (Tasmota) but then I do not get the temperature sensor reading.
Am I doing it wrong? Or is this model with a temperature sensor not supported? Thank you!

You should probably consider using the Tasmota app instead.

Thank you for your reply. I was about to ask for more advice or ideas on where to read about it but I am glad I tried again and again on my own because I finally found a tutorial that worked. When I looked into the MQTT broker app today, it looked like it crashed. Do I generally need a flow to restart it every now and then or after Homey loses power? Or is it even not needed once the device was added through tasmota app?

The MQTT broker is mandatory for the app to be able to communicate with the device, so it should be running all the time. As with all apps that are installed on Homey, it will automatically be started when Homey powers up.

I don’t know about any issues with the broker app that cause it to crash, but if it happens often, a restart every now and then may hopefully work around that.

Great, thank you! Do you know anything about adding devices from Homey to Homekit? In general all of them always worked for me but in this one case, I do not get the temperature reading. I can control the switch but nothing else, no information about the temperature. Originally, my sonoff was configured to work with with homekit and I could see the temperature reading but then I was not able to see it in Homey and I like to combine the two in some cases.

The Homekit implementations for Homey don’t map all Homey capabilities to Homekit characteristics.

1 Like

Hi again!
Now I got Sonoff TH10, I flashed it with the latest Tasmota Sensors soft but when I try to add it to the app, I get the “No new devices found message”. Am I doing something wrong? It has a humidity and temperature sensor connected to it. According to the shop (and the info on the PCB) it is an AM2301 sensor however when I configured it according to this information, I was getting null values. When I selected Si7021, I was able to read the temp, humidity and dew point. It works with the Tasmota app but is there a reason I cannot get it to work with the Sonoff app?

Edit:
It also works when I add it as a Generic (Tasmota) device but then as above, I do not get any sensor readings. I am wondering why I cannot add it as TH10/TH16 (Tasmota) even though it is a TH10 with Tasmota.

Thank you

Probably because the Sonoff app has been deprecated, it has only been tested with old versions of Tasmota.

So would you say that the Tasmota app is currently the best solution? Are there any differences in the functionality after adding the devices through one or the other? I would generally not mind flashing the Sonoff with an older version of Tasmota if I would gain some functionality. Are there any differences in how they map homey capabilities to Homekit characteristics (as you wrote it)? I am asking because today I added a SNZB-02 sonoff zigbee sensor to Homey and I immediately got readings from all sensors in both Homey and Homekit.

Both the Tasmota and my Sonoff app only deal with WiFi devices, the Zigbee app is separate.

I stopped developing my Sonoff app ages ago and cannot guarantee that if you install an older version of Tasmota it will start working. The Tasmota app is more recent, and (I think) in active development, so it would be the better solution. However, I don’t know how well it supports additional sensors, so you’d have to try.

Thank you for your reply!