ITEAD Sonoff

Hey guys, does Sonoff R3 dual works with Homey?
I would like to use it for lights and also for outdoor blinds but I can’t find it in the list of supported devices.
Thank you

Hello. Is Sonoff Mini R2, wi-fi Smart switch with DIY mode compatible?

Possibly only with older Tasmota firmware (for which the Tasmota app is a better choice), but certainly not out of the box.

1 Like

thanks…I am ready to change firmware but idk which version of tasmota firmware should I use. Could you please help me?

You should use the Tasmota app. I think it’ll work with the latest version.

Sonoff 4ch pro 2 is it compatible with the app?

Probably, but only running older Tasmota firmware.

Ok, so if I buy a 4ch pro 2 with new firmware, is it possible to downgrade it to an older version?
And how do it?

I don’t know if newer versions of Tasmota will allow downgrades. Perhaps you should consider using the Tasmota app instead.

This app became redundant some time ago. Don’t bother with it. You’ll be wasting a whole bunch of time. Your better off flashing your device with the latest Tasmota firmware and using Homey’s Tasmota App.

Thanks for repeating what I just said.

1 Like

Hello. FYI: It seems that Athom has done some “improvements” (into the 7.1.3 release), which seems to affect the flows, namely I have a Sonoff RF Bridge which’ codes are not taken into account by other flows anymore (I see that the MQTT part is OK).
Other than that: during troubleshooting I have removed the RF Bridge from Sonoff’s app, and when I tried to add it again, it was not successful (ver. 9.5.0). After I downgraded the RF Bridge to (Tasmota 9.3.1), I had the success again. Have You heard of other responses about adding devices with these Tasmota versions into Sonoff’s app? Thank You in advance.

I’m not aware of any changes, Athom also hasn’t warned developers that there might be breaking changes in 7.1.3 :thinking:

That said, my app has been deprecated, it was only tested up to Tasmota v6 or v7. There’s a dedicated Tasmota app what may work better, although I’m not sure if it supports the RF Bridge.

Well, I have also tried to send some “feedback” to Athom directly, perhaps it is some bug or issue with my Homey device. E.q. when I run a manual flow test with output to Timeline , then the manually added code is not shown (when using Android’s app) and it is shown when using PC based GUI…

I am using also this app, but as far as I remember, then the RF Bridge is not (yet) supported…

Athom made some changes to SDKv2 that broke the Sonoff app, I created a workaround. You can install a test version of the app from here: Sonoff | Homey

Let me know if that solves your problems, if so I will do a proper release.

Thank You for the super-fast response. The test-version works nicely and and RF Bridge’s code-words are working again !! I have also a ticket open with Support - shall I notify them that You have found the solution?

My guess is that support will refer back to me anyway, as they tend to do :wink:

It’s now been released as stable.