Integration with Worx Landroid mowers

That is worth a try. So you mean
Condition: any status
AND: status mowing
THEN: do the magic

??

Yesss

Works like a charm! Thanks a lot for the hint.

Trying to download but install button is not available. Any tips?

2 Likes

I’m currently looking for robotic mower option, seems thanks to Homey integration, Worx might be winner… can someone please post flow card options (incl. and and then actions?). I’m interested if it’s possible to trigger rain detected from Homey because of the rain/sun garage I’m considering as well…
Thank you.

Then:

And:

When:

Lots of options under the error and status options. Rain included. Guessing this will vary between models.

1 Like

Thank you a lot - but this is just status, right, eg. you can’t force “rain detected state”…

Yes. Just statuses reported from the mower. You can’t force rain detected, no. Unless you poor a bucket of water on it :stuck_out_tongue_closed_eyes:

1 Like

FYI, seems that also Worx Landroid M500 Plus (2nd generation) works so far fine (at least I see data).
Btw, checking ioBroker in parallel, seems there are also some other interesting attributes like… I guess @Martin_Verbeek it’s not something you would like to implement, right ? :wink:



Anyway, thank you for your Homey integration, actually I’m surprised seeing it only in the Community app and not the official store but I don’t mind…just actually found it accidentally while it deserve official place.

Hello same problem for me. Have you found a solution.
Thank you by advance

Are you logged in ? Have you installed the Comm.store addon on your Homey?

Anyway, it’s not related to this app, so you may want to ask in the HCS thread.

Btw, just to let you know, Martin has released new version with added new parameters :slight_smile: Looking forward to have those new parameters also in Insights :slight_smile:

V2.2.0

Added some informatinal fields (gradient, inclination, timeExtend, batteryVoltage and Temperature

Hello Sharkys

I have tried to installed it without sucess with folowing advise (install small software on my window 11 computer). My computer, my mower and my homey are on the same 2.4ghz wifi network but instalation option from aplication still not available.
I will tried to asked help to the HCS tead as you sugest.

thank you

stéphane

1 Like

Hi @Martin_Verbeek

Thank you for your great work. I successfully installed your app on my Homey, but I can’t add my Landroid WR141E. I just get the message “No new device found”
Should I do something else before trying to add my automower ?
Landroid is connected to wifi, I can see it in the official Landroid app and the integration in Home Assistant is also working, so I don’t think that the device might be the problem.

Thank you!!

EDIT : Forget it, I found the solution, just had to go to the settings and add my Worx credentials … Sorry ! I’m still a beginner with Homey :slight_smile:

1 Like

:sweat_smile::sweat_smile: no problem, when any issue or question or ask for improvements, drop me a message

Just waiting for Insights and it will be absolutely perfect now :slight_smile:

are these okay?
image

1 Like

You are the best! :slight_smile: Thank you, it looks fantastic… finally I can disable MQTT integration for Worx :slight_smile:

@Martin_Verbeek can I help to troubleshoot this somehow?



App restart resolve it always…

Is this message after the restart? If not could you pm me large chunk of log previous to the restart

Martin Verbeek

Unfortunately it’s just before the restart :frowning: That’s why I decided at least to share state of the app and device. After restarting there isn’t any errror in the log, all seems to be normal. It happens like 1-2x per a week, nothing serious.