[Howto] set a value to a virtual device

What App shows the energy prices?

That is the awesome Power by the Hour app :wink:


Following this guide I am trying to get the temperature from a philips hue motion sensor, but I am getting the following error:

measure_temperature InvalidTypeError: [null] is of type string but expected number (invalid_type)

Any ideas?

Can you share a screenshot of you flow?

It looks as if the value of the hue capability is null, which is not allowed as number-argument-value.

I tried a few different things, and I think I got it working, the flow looks like this now:

However, the idea with this is to be able to ask GH about the temperature, and when I tried first time after making this flow, it told me that the sensor is turned off.
I then clicked on the virtual sensor and set a temperature “20C” and it now tells me that the temp is set to 20C and that the actual temperature is 21.5.

However, the actual temperature when I click on the Hue motion sensor shows 22.1C not 21.5, so not really sure what is going on there?

Also do I have to set a temperature manually like in this example, for GH to understand that the sensor is on?

That trigger will only trigger when it goes from under -10 degrees to above, not every time the temperature changes, you’ll need to use the “temperature changed” trigger for that.

Trying to configure a sensor for the living room, but I am unable to get any readings at all.
What am I doing wrong?

What do you mean with:


First of all, please add notification / log cards to flows which won’t do what you expect. Then you can trace what worked or not.
Second, make sure your virtual device has a “measure_temperature” capability, otherwise it won’t work
Because in case you selected an other type of capability, it is like you want to set the, say, humidity of a light. That won’t work either.

Screenshot from 2023-05-26 01-12-04

In case you’ve added a virtual thermostat instead, you also have to tick the “measure temperature” box to get it to work
(Note you can’t edit a VD, so you’ll have to create a new one)

I made a test VD and a test flow;
As you can see, the top flow is like yours,
but the bottom flow is to send a manually entered number, just purely to check if this measure_temperature I entered will accept a value or not.

Screenshot from 2023-05-26 01-18-29

I’m pretty sure the issue here is, you didn’t select the “measure_temperature” capability when you created that VD.

I hope this helps you further with the VD’s

The issue above made me think of a feature request:
The ‘Measure temperature’ box isn’t ticked when a virtual thermostat is created, only ‘Target temperature’; Shouldn’t that box be ticked by default?
While most thermostats have a settable temperature ánd a temperature sensor?

(made a ticket for it)

Before i posted, i looked at how a VD would look of not selected the measure_target during creation.
Since his image has a Actual Temperatur with a dash above it, i actually think he did select measure temperature.

Lets see his response :wink: