Homeyduino: Unknown Error occured, no adding in homey possible

I‘m running the actual versions of homey and homeyduino.
I have the original Arduino.cc Rev 3 and the original Ethernet Shield 2. The necessary libraries are integrated.
I used the following recommended Sketch, which I uploaded to Arduino ( with the Macadress sticked on the shield):
#include <SPI.h>
#include <Ethernet2.h>
#include <EthernetUdp2.h>
#include <Homey.h>

byte mac = { 0x12,0x34,0x56,0x78,0x90,0x11 };
const char* name = “Homeyduino1” ;
void setup() {

void loop() {
// put your main code here, to run
I can find Arduino in my AVM7490 Fritzbox Router, it is active and got an IP-adress, I fixed the IP. When starting now homeyduino the Arduino is not automatically recognized. Then I enter the fixed IP manually and I get then after a few seconds the message : „an unknown error occured“.

What could be here wrong, could anyone help? Do I have to do anything to activate UDP-Broadcast in my Router?

Your code doesn’t match the basic example; specifically, it doesn’t call Homey.loop() inside of the loop function.

1 Like

Thank you very much, sorry it was my mistake, now it works.
I uploaded now the remote configuration script to Arduino and want to control everything with homey.

Do you know how to include the state of the inputs/ outputs to homey. There is no Flowcard. I tried as workaround to configure a flow and to switch a virtual device depending of the state of an digital input.

But I can in the condition card only define a pin, but I can‘t change the tag, so that I can‘t differentiate between yes and no in the case of an digital input.


That’s what capabilities are for. You declare that your device has, for instance, an onoff capability, and in your Arduino code, you set the value depending on the state of the GPIO pin (high/low). When the capability callback is called, meaning that the state got changed on the “Homey side”, you change the state of the GPIO pin.