Homeyduino no update of trigger after update to new pro 2023

After I moved al my devices from my 2016 towards the new pro 2023 I have some problems with the updating of the values with a trigger from the ESP device.

This is the line on the arduino:
Homey.trigger(“temperature2”, tempDev[1]);

I’m reading it the same as on the old one:

But sometimes it takes a while for the value to change.

The trigger is by the way send when the temperature is changed for 0.2 degrees. Which always worked fine.
I don’t hope I need to change the arduino software so that it is always sending every X-seconds, because there build in good :wink:

I don’t use the Homeyduino, have no idea about Arduino and haven’t searched the forum for similar problems, but it sounds like a app problem to me.
And if you can exclude own mistakes and have already tried a few things, e.g. recreating this flow, restarting the app, restarting Homey, and were unable to solve the problem that way, I would therefore suggest to contact Athom, the developer of the App.

Thanks, I allready solved it.

Deleting and re-adding them did the trick for now.
Maybe it was still wanted to send some data to the old Homey which allready is off.