Homey Script for Garmin Watch

Hi everyone!
I’m looking for a friendly enthousiast who wants to help me with my Garmin Watch. Cold beers are on the way as soon as we got it working. I found this app in the Garmin Connect IQ Store Connect IQ Store | Free Watch Faces and Apps | Garmin
I would love to use this app to switch on/off virtual devices and/of scenes. Does anyone have experience with this?

I’m just at this skill level where I really see the use of more advanced flowcards/scripts but not skilled enough to understand where to start.
Any help is really appreciated!

Hi, I created a widget which is pending approval for the Garmin store.
I will create a topic with information how to use. Then you can view your favorite devices, press buttons, toggle switches and start flows.

For the app you linked you need to use the Athom WebAPI. And you have to use an auth token for Authentification (http header field). But the WebApi is returning very large JSON data you beed to parse in the App. I don’t know if it’s possible with this app.

So please wait a short time. I hope my Widget gets approved the next days.

Edit: Only watches with more then 64kB available widget memory are supported, because the JSON data is so large that the memory limit will kill the widget. @DvStarrenburg : What watch are you using?

Sounds great! I use the Garmin Venu SQ Music.

The “music” version is ok. The “small” VenuSQ has only 64kB widget memory and ist not added as compatible.

The Garmin widget is ready to download.

It’s still alpha version. And you need the Homey cloudID and the session token for WebAPI access.

1 Like

Aweome that you’re making this!

I bumped into a problem though, that I can’t seem to figure out. When I’ve added the cloudID and the auth token I get the message “Set app settings” when I open the app on my Garmin Fenix 6 Sapphire, I can also go to Devices and Flows, but they both state 0. I tried adding the “Bearer” in front of the token, but then it just stated that the session expired, so I assume that not having the “Bearer” in front was correct?

You have to copy the whole value. Here is a screenshot from Firefox:

Best way to find the needed http call ist to search for file “/api/manager/system/”. That are API calls where the toke is used.
You have to copy the whole value after “Authorization” including the "Bearer ". It can happen, that the string is displayed with a linebreak if the window is too small. Don’t miss this part.

1 Like

Coped again and now it works :grinning:

Devices seems to trigger fine, but when I try to start this flow it says “Starting flow…” for half a second and it goes back to showing the “Flows (1)” menu and nothing happens.

Thanks for the feedback. I only tested with advanced Flows. The API call for standard flows seems to get an http error. I’ll check this and update the app when this is fixed and give you a feedback.

1 Like