Homey Pro - Challenge with Z Wave associations - secure/unsecure - node groups and commas

Hi all,

new to the forum. I have a Homey Pro and several Z-wave devices;
Such as Heat-it thermostats (trm2fx) and dimmer (Z-dim), as well as some hidden/in-wall dimmers from Namron and NEXA, and some wall switches from Namron.

I have suceeded in setting up the the Z-dim dimmers and the thermostats, they are set up as “unsecure” devices (dont ask me how/why), following the instructions in the Heat-it app.

I can control all of my devices from the Homey app on m smartphone.

Now I want to be able to control some of the Namron/Nexa dimmers (AD-146) with the Namron switches. Her I am struggling.

Namron dimmer controlled by Namron switch:

From what I understand I should just add the node ID of the dimmer in group 2 of the switch, and then they should be paired. No configurations needed on the receiver side (dimmer). But this does not work. I have tried to make sure the switch is “woken up” before saving the assoication settings under the switch, in the app. Does not help.

I am able to pair the two manually, but this works really slow and laggy. Sometimes have to press the switch 2-3 times for the dimmer to respond. Both switch and dimmer from Namron are setup as secure devices (dont ask me how/why), is this the reason for them being so slow? Also, there is no stored info (node ID etc. under group) in the app about how these two devices are connected. Shouldn’t it be visible? Or is it an internal connectio between the devices not visible to the Homey?

NEXA dimmer and Namron switches:

Setting up the NEXA switch with the Homey Pro was much faster than with the Namron switch.
But I simply cannot get the Namron switch to connect with the NEXA dimmer. I have tried both manually following instructions, and by entering node ID of dimmer in group 2 of switch. Now the NEXA dimmer is setup as unsecure (dont ask me how/why), and the Namron switch as secure (dont ask me how/why).

I have also tried using comma, and add the node ID of receiver in group 1 of switch, but the Homey app will simply not accept me using commas, in any groups, in the app. Even if I see people are using it all over the web in their configurations.

I have also tried to control my Heat-IT z-wave dimmers (unsecure) with my Namron switches (secure)

  1. Is it not possible to connect secure Z-wave devices with unsecure devices?
    (If not, then why is this not clear on Homey? if; how can I achieve this)
  2. Why can’t I enter node ID of receiver into group 2 of switch and make it work? What am I missing?
    (nothing happens, even when making sure switch is woken up before saving config/settings/assoic.)
  3. Why are using commas not possible, for using several nodes in same group in Homey app? (v2.0)
  4. If I need to make all my devices unsecure for them to work, how can I conveniently do this without use of Command Line Interface (CLI) ?
  5. I have read something about you need to have your z-wave devices close to your homey when adding them for optimal performance, and to get them secure. But I don’t neccessarily want/need the secure option. Particularly if it is the reason for making things unstable and slow.

Many questions, but I am primarily struggling to understand why I cannot easily connect different devices from withihn Homey by using node ID’s/groups, and does secure devices make it impossible to connect with unsecure devices.


Short story: Associations works only if both devices are secure or both unsecure.

Solution: include the devices unsecure:

Thank you for your reply.

Not sure I understand how to do this still. You saying that I should add eg the switch, via the unsecure dimmer, to get both unsecure. How will the swithc then be picked up by Homey? Will have to try later when get home.

Got this working. But not by adding the last forced unsecure device. But by adding one of the Heat-it z-dimmers which were unsecure, then it installed the namron switch unsecure. Now I was finally able to manually configure and add associations in groups, easily.

Also, the comma problem was because my keyboard on my phone automatically added a space after the comma. When I removed the space so device-ids was just separated by the comma and no space, then multiple devcies could be added to same group.

All good.

This post helped me a lot, thank you!
However, after adding the Namron wall controller as unsecure none of the scenes associated with some of the buttons are working.
Any ideas?