Homey Community Forum

Homey list -> stripped.split is not a function

Hi!
I would like to start the developing for Homey… but I am stucked at the begining.
I had a node.js, but updated to the latest one.
then:

  • npm -g homey
  • homey login
  • homey list : and I got an error message: “stripped.split is not a function”.
    I don’t know why…
    After that I tried to do something else… for example homey select is working… unselect is working…
    After I “homey app create” , and I select my Homey Pro, tried to “homey app run”, but I got a Homey Offline message.
    I tried to restart but nothing changed…
    Any Idea?

Better use the same version node.js as Athom does, and that is not the last version. You can find it in the mobil app.

Are you running Windows by any chance?

It looks like one of the dependencies of homey was broken for a short while. Try cleaning the NPM cache and reinstall homey again:

$ npm cache clean
$ npm i -g homey

If that doesn’t work, try this and see if homey works after it:

$ npm i -g cli-table@0.3.9

Thank You!
I tried it on 2 machines yesterday… I work on OSX, but I tried on a windows 10 machine, and same result.
Now after clean cache, and reinstall, The ‘homey list’ is working, but the ‘homey app run’ still not.
I installed the same version of node.js (12.16.1), but nothing changed.
But yesterday I tried to disable the internet connection of the Homey IP address, then I couldn’t find it , so I give it back, then I noticed in the app it connection was local, not cloud… I tried ‘homey list’, same error, but I could run the ‘homey app run’… It worked…
But today it is connected via Cloud again.
‘homey list’ result is:
│ 60a…ace │ Peter’s Homey Pro │ 7.2.0 │ 2 │ en │ 1 │ owner │ Yes

[Mod break: privatized cloud ID]

The Node.js version isn’t relevant. Why is it saying “Yes” in the USB column?

Also, what do you mean by “I tried to disable the internet connection of the Homey IP address”? Homey requires a working cloud/internet connection.

And please remove the ID from your post, it’s sensitive information :woozy_face:

It is connected to USB.
I disabled in the routers firewall… and then enabled… but it is still in cloud… and i can’t run ‘homey app run’… ‘Homey Offline’, but it is not.
I noticed, when the Homey connectiion was local it worked.

I connected my laptop with cable to the router… Now it is working.
Maybe some wifi isolation settings caused the problem.

Can you use the Homey app on your mobile phone to control Homey? If so, it might more complicated than that (Athom uses some funky DNS stuff to allow HTTPS access to a local Homey, but their method is questionable and some routers don’t like it).

My mobile app is working. (I can change the brightnes of the ring).
I use the 443 port forwarding for anything else…
I think the CLI use local connection, to reach, or upload to the homey… and if my laptop is on WIFI, then can’t reach it, because of some isolation settings in my router… but if I connect my laptop with cable, there is no problem.

But your phone is on the same WiFi and it can access Homey. So it sounds like an issue with homey mistakenly thinking your Homey is offline, and not with your router. Or possibly your laptop (if you’re using a “personal firewall” like Little Snitch, Lulu, Scudo).

I use Little Snitch, but it can’t make difference, if I use WIFI or cable. ( I tried to turn off Little Snitch) So it can’t cause this problem. I think I can reach with my mobile app with cloud service… not direktly… I turned off the WIFI on my Phone, and still working.
But there is a next problem… my Android 10 Homey app is often freezing… when I start it, just white background, rotating circle… endless… I drop it from the memory, restart Homey app, and nothing changed… Only android reboot is helping… same on iPhone… :frowning:

Perhaps it’s time to contact Athom support: support@athom.com