Homey Community Forum

Homey and Verisure

Can’t even login to Verisure in the Homey application. I have added a new and dedicated user at Verisure that can use the app.

Anyone know what to do?


Same here =(

I’ve been trying for months to add the Verisure sensors, with no luck, untill tonight. I found out that I have to arm the alarm and then turn it off again, right before trying to add sensors to Homey. I also read somewhere that the driver should be added last.

This is what I did:

  1. Uninstall the Verisure app from Homey, then install it again, for a fresh start.
  2. Enter login info in the settings section.
  3. Arm Verisure alarm (using Verisure mobile app), then turn off again.
  4. Add Verisure sensors to Homey.
  5. Add Verisure driver to Homey.

Hope this works for you :slight_smile:

Thx! Yesterday they updated tha Verisure homey app and now I can at least login :slight_smile:

I have only implemented the driver and my smartlock in the flows at the moment. You have any great idea how you gonna use the sensors? Get me inspired :slight_smile:


The Verisure API is having some issues that i am working on. i wil update the app this weekend.

Kind regards,

Could that also be the cause that I can no longer login with my iOS apps for Verisure?
I can login in the mypages website though.


The issue with not being able to login to the iOS app seems directly related to the new Homey Verisure app. When I deactivate the Homey Verisure app, wait approx. 30 minutes, I have no problem of logging into iOS Verisure app. When I reactivate the Homey Verisure app, I can no longer login with iOS apps.

Nicely enough, the logged in iOS app, remains logged in (for the time being). This was not an issue with previous versions of the Homey Verisure app, however, it may also be that Verisure changed something.

Edit again: Verisure iOS app logs out automatically after Homey Verisure app is activated.

Root cause appears to lie with changes made by verisure. Verisure: “Your account sends too many requests to our system and the account will be locked temporarily. Probable reasons for this are to use some kind of home automation, such as Homey or Home Assistant. To correct this problem, you need to adjust the number of requests the application makes to us. Our acceptance is based on a request per half hour. When this is adjusted, the latch releases within a few hours”

see: https://github.com/Charlie-Root/homey-nl-verisure/issues/32.

Using the app, is it possible to have a zwave button arm/disarm the night mode of the alarm?


1 Like


My app crashes all the time since the 2.0.0 version. I’m I the only one?

Unfortunately not, mine keeps crashing too.

Is the Verisure app working for anyone?
I just downloaded it, signed in (settings). But when I try to add l a device, e.g. a sensor, it just remains at “Follow the instructions…”.
I’ve tried arming/disarming the alarm, opening the door, but nothing!

1 Like

its the same for me, it stops with follow the instructions when I try to add a device (smoke detector) anyone who have any news about this issue?

app is crashing when i want to add sensors

I cant get any sensors to work or arm/disarm…I have tried armin/disarming opening the door etc nothing happens just times out

Whatever I am wondering is there is something being developed on this app. Or will it no longer be supported in the latest homey version? Or is there another reason why it doesn’t work. Perhaps the original author can say something about that. To which there will be no update is also an answer.

Hi @CharlieRoot! It would be amazing if you could have a look at the app - since it does not seem to work at all on the Homey Pro’s. I believe many would be very, very grateful for your efforts :slight_smile:

1 Like

I have also just purchased a Homey Pro and i cannot get the Verisure app to work. I can login with my credentials and after that i´m asked for my personal keycode. But everytime i configure the Verisure app i have to enter my personal keycode and when i try to add components i only get “null, null” on the alarmsystem and timeout on the other components.

I have the exact same problem! Did you get it fixed?

Same here. Just bought the Homey PRO and one of the main reasons was this Verisure integration. If this is discontinued it should be removed from the site, as it serves as misleading marketing.

Mine is working well and has done that for a while. I guess that you tried to configure all over again? Enter your credentials, and then arm the alarm ones or twice. That could fix the null problem.