Høiax Connected smart water heaters

Getting my 300L in a few days. What options do you have for the effect steps on the 300 L
Manual only gives info on the 200L

According to an earlier post, it seemed to be:
0W, 1250W, 1750W and 3000W

Får feilmelding når jeg skal koble opp appen.

Har en ny 200.


Thanks for the report, I will post an update this evening that fixes this.
Meanwhile, restarting the app might help. If not please wait for the update.

The bug has been fixed in version 1.6.7.
It has been pushed for testing here: Høiax | Homey
If it doesn’t cause any trouble it will be pushed out to everyone tomorrow evening. If you don’t want to wait please feel free to install the test version :slight_smile:

I got this now


Yes, the last one is expected to some degree as I assume yor internet connection is very rate limited based on the original error. Nevertheless, the driver will now retry for eternity to get a connection so this should eventually resolve after a few minutes.

The first one was a bit more surprising though, as it might suggest that the Homey struggle with completing its tasks within time. It might be related with the internet connection issues though.

I might have to make the app more robust to these issues though if this makes the app is very unreliable in your location. Am I correct that this is over a mobile internet connection from a cabin where you only get rate limited when you are not present? If so I could have an away mode that rate limit the device only when the internet connection is expected to be limited. (Allthough it will not resolve the similar issues between your tank and myuplink though, in which I have no control over.)

I’ll see if I get more time to improve this in the evening.

I tryed to reinstall.
Remove, reboot and install beta 1.6.7


I have seen this also…

The app myuplink is working…

And i can see that the settings is changing from økonomic to extern program :slight_smile:

So there is some communicatipn there.



Just got my Høiax 300L installed today and have the same problems as EddieX :slight_smile:
Tried the test version as well.


Alf Jonny

Odd that this happens now for you both at the same time, wonder if they have changed the communication protocol with the newest tanks. I’ll check if there are any updates to the protocol.

Is this a persistent problem for you both or did it resolve during the day? If the failsafe mechanism I added did not resolve this during the day then the protocol must have changed.

@frodeheg, still not resolved by itself. Tried everything basic, like removing tank from Homey App. Reinstall App, still the same. Let me know if there is anything I can assist you with.

Thanks for the feedback. I was planning to add some debug code yesterday to get out more information but unfortunately there was no time. I will do my best to investigate this issue this evening.

I notise that when i install the app and add connect to cloud it actually login one time and change the program from xxx to extern program.

But the app shows error.

This means that there is a some communication

I see that the app settings is missing «Northpool» info…


While I am investigating it, which firmware versions do you have on the tank?
(I think you can find it in the myUplink app under the middle icon at the bottom → “Profil” → “Enheter”. For my tank it says “Versjon: 1.5.6”)

I am very puzzled by this and cannot get it reproduced for my Connected 200 tank.
Can you confirm that you both have:

  • Høiax connected 300
  • Firmware version 1.5.6 (see above)
  • myUplink API version 1.21.1 (46) (in the myUplink app, click the middle icon at the bottom → “Innstillinger” → “Om myUplink” → “Versjonnummer: 1.21.1 (46)”)
  • A reliable internet connection for Homey.

A new test version v1.6.8 is out now that just does two things:

  1. print more debug info to me in case you send me a new crash report (not sure how you did it, I was surprised I even got it, never seen it before)
  2. Ignore reading Northpool settings if it cannot be retrieved (not sure why it should be a problem, it works fine with me) - Anyway, if this fixes it, maybe I just should remove the option as I rather would recommend you to install my other app “Sparegris” which will not only give you better price control but also make sure the desired power tariff is not breached.

If this does not solve it I will add an app settings page tomorrow night that will allow you to see the internal app log and send it to me.

Fingers crossed…

@frodeheg, thanks for making your time on this.

I have just tested 1.6.8:

  • Høiax connected 300 // YES
  • Firmware version 1.5.6 (see above) // YES (1.5.6)
  • myUplink API version 1.21.1 (46) (in the myUplink app, click the middle icon at the bottom → “Innstillinger” → “Om myUplink” → “Versjonnummer: 1.21.1 (46)”) // VERSION: 1.23 (2262)
  • A reliable internet connection for Homey. // ALTIBOX FIBER NO PROBLEM

Get this error message this time:

Please use this if it helps, Troubleshoot report within Homey:


Alf Jonny :slight_smile:

1.5.6 :slight_smile:

Connect 200



Thanks for the final Diagnostics report I got on mail @EddieX, this explains it all.

It seems like for some reason Høiax has decided to discontinue the ability to use price control on their tanks so a lot of parameters are now impossible to read from the tank if you have myUplink version 1.23 (2262). From version 1.21.1 (46) it is still working though.

It’s an easy fix so I will just remove these features from the app for now and replace it with a better system instead.

I will also reach out to Høiax and get them to send me warnings in advance next time they break their API. If I had been informed in advance it would have saved both me and you a lot of time.

Ok, version 1.7.0 is now out for testing. It should most likely fix the issues.

If it works it will probably not make it into the stable build before Monday as this requires Athom staff to accept the change.