Error Panasonic Comfort cloud app

Just received an update to v1.3.2.
Hope this will fix this issue because the changelog is

1.3.2 4 jan. 2023
Fixed change in panasonic API

Hey guys,

Happy new year!

Panasonic had made a change regarding charsets and also bumping the version of their API. They use two kinds of versioning at their end, which pretty constantly changes. Im not sure about their practices, but i’m sure they have their reasons.

As far as rate limiting go, i have not experienced any. I’m pretty sure the guys at Panasonic found an “excuse” as they were unable to find any other reason for the failures. Looking at the request headers would have made the issue very clear imo.

It is true that the app authenticates on every action made against the API, but that is something that had to be done, as the token provided by Panasonic has an extremely short TTL. Making multiple adjustments to the device would result in token timing out. I have logged in 20-30 times in a row, without any issue. Any rate limiting would have blocked me from doing that. But i will monitor, and please lmk if encountered.

I’m sorry for the late fix (been away for an extended period) and hope it works for you guys as well.


Thanks for all the good work!

I received the update indeed in homey.
I reset the app
I can’t connect to the units, they give error 429.

That would that error mean?

Good to see you back @lumin!

Rate limiting was my personal conclusion seeing authentication requests failing with HTTP status 429 (“too many requests”). Once I disabled your app, this stopped happening after a while.

Before I added re-authentication logic, my app ran for at least a day on the same token. Maybe Panasonic has improved the TTL?

Same here; error 429. @lumin Seems like there is an issue with the requests.

Hmmm. Weird. Working good with my device :see_no_evil: do you guys by chance have multiple devices?

Allright, let med add some new logic for auth, and lets see if panasonic has improved their handling of tokens :+1:

I think that might be it. I have three units. But even without sending a command I immediately get the error.

I have 4 units

Guys, once you receive HTTP status 429, your credentials are blocked from authenticating with Panasonic servers.

They will start working again after a while (at most 24 hours, in my experience).

There’s nothing you, @lumin or his app can do to circumvent this - except using other credentials.

The number of units is probably relevant in that more requests will be made (but I also have only 1 device).

Do you know how the relation is between account, Panasonic Id, devices?

As I understand it: account is a Panasonic Id. And a device can be linked to multiple accounts.


Devices are linked to a Panasonic Id. And an Id can be linked to multiple accounts.

A device is linked to multiple Panasonic IDs, but only one ID (the first?) can be the device owner. (So, your first option.)

Why are you asking about “account”? If you need to use the term, I’d say the Panasonic ID identifies an account.

Same here.
After the update this afternoon it worked for me with 2 devices.
Just did a app reset and also get a error 429 and exclamation mark in de device tile.

Sure, but that still means it’s the app that’s doing it. I had no issues before. So, I can wait but then the app probably will make too many requests again.

You are right, I should call it Panasonic Id.

So, is it correct that with two Panasonic ID’s you can maintain with one ID a working Panasonic comfort Cloud app (without the internal server error) .

And the other account you use for homey, (getting the 429 error).

At least with this setup you can still control the devices via the original app, correct?

Exactly, that’s worked for me since this started happening. I’ve kept the owner ID in Android (crucial for the ability to approve device access), and a “guest” ID for Homey.

Fyi, I deleted the homey Panasonic app. 12 hours ago. And now I can login into the original Panasonic cc app again. (With the same Panasonic Id as I used in homey)

Confirming the hypothesis discussed above. That the homey cc app is disrupting the used Panasonic Id.

1 Like

I created a second Panasonic id in the Panasonic cc app. I added just 1 of my 4 devices.

On homey I downloaded the PCC app again.
First I added my second Panasonic id in the app settings.

Then I added a new airconditioner.

I get the error message:
Sqlite_contraint: not null
Constraint failed: device data.

What might I be doing wrong here?

Edit1 Oops used wrong password. Trying again.
Edit 2 yes, it works, added 1 device in homey. Now let’s test if this is a stable setup the next 24 hours.

24 hours later, the one device I added in homey gets a 429 error again.

Remarkable is, that I do not get the internal server error when I use the homey Panasonic id, when logging in to the original pcc app.

Still no update on this? It shouldn’t be so difficult to (re)use the token instead of logging in every time again?

1 Like

For what it’s worth, my alternative app is now available on Homey Community Store.
Technically, this is the same as installing it from the repo using the SDK, it’s just more convenient if you’re not a developer. (Please do not ask me or this thread about HCS.)