Cannot Activate a New Homey Pro (Early 2023) in first time install

I just received my first homey pro. It is not activating. I can connect to wifi, the app finds it, but when it goes to register it, it says that it cannot be activated do to an invalid token. I tried to open a ticket but it says it will be 2-3 weeks before I get support.

Is there a way to get this activated and working faster?

I have read the rules - so thank you.
Unless I’m blind I couldn’t find anything about this activation error.

Thanks in advance for any assistance.

Do you have a specific network configuration?

Fe usung a pi-hole or firewall configuration?

Can you simplify it by temporary disable fe mesh routers or use a temporary hotspot.

Else you need to wait on Support. But that probably is faster than the communicated weeks.

Thank you for the quick response.
I actually thought about that; and connected to a t-mobile hotspot - with ample signal; and it still didn’t work. No firewall - or any special configuration
It acted like it was going to work; did a firmware upgrade and just sat there for over an hour

Would it just be quicker to order another one and send this back?


Can you try if you can update from a computer using a USB connection?

Filow this guide

Else check tomorrow if they respond on your support request

I Had the same problem yesterday and athom support helped me to solve it :slight_smile:

logout from and deinstall/remove the Homey app from your device.

Restart the device.

Install the app again on your device again. Login in the app again.

and start the + add device option…

(worked for me ! (thanx Peter! :wink:))
Support said that the login token for your app/device was lost/timed-out and could cause the problem.