Blink Camera App - Issues?


I’ve installed the Blink Camera App on the Homey. When i add a new Blink device i.e. Indoor Blink Camera. I immediately get the following error “Cannot read property ‘name’ of undefined”.

Anyone advise on this one? Does the Blink App not work?

Hi, yes it`s a known bug. The new test version is already published and will fix this problem.
Please take a look at this thread:

I installed this new test version 1.0.8.
Unfortunately I’m still getting the exact same error when adding a blink device?
Can you confirm that this really works?

Hi, I tested adding a outdoor camera with the test version 1.0.8. It’s working well.

Please check, if the test version is installed (with the blue icon)

Hello again,
I tested again and now I got the error. I have to investigate if there are difference between Blink Mini and Indoor/Outdoor, but it will take some days until I can give you a response.

Hmmm, tested again and now it’s working again. I’m wondering if it’s something around the login not done at this moment.

I tested now several times with a Blink Outdoor camera and ist working well. I can’t reproduce the error.
Please can you describe your situation?

  • is it your first cam or do you have already a cam installed?
  • what camera are you trying to add?

I think I’ve found the bug. We have to fix it and publish a new test version.

I have several existing Blink Indoors and a few Outdoor Blink XT cams.
After selecting the add devices, blink app and then select continue. I was getting the error = “Cannot read property ‘name’ of undefined”.

However, having recently restarted the blink app; I was able to get pass this error and now have managed to registered all cameras against the blink app within homey.

Not had a chance to play about with this much. However, when viewing the camera icon under each camera i notice a strange intermittent issue from time to time.
When first viewing the camera snapshots they worked fine, but after a few tries i ended up getting an error -“invalid_content_type”. Restarting the blink app did not fix this, however leaving it after a set period and all was well again.

Thanks for sharing.
The add camera problem is caused by a bug in the app - some kind of race condition due to asynchron execution.
That means: sometimes it’s working after a restart of the app, sometimes not. We’ll fix it with a new version.

The image error occours, if the camera is busy (recording) and no snapshot could be created. This can happen, when you raise the motion alert before creating the snapshot. The app waits up to 10 seconds for a snapshot, after this period, the error appears.

1 Like