App store reports "An app is already being installed on Homey. Try again"

So I got a brand new Homey pro and installed a bunch of apps. No problem only three apps are not in the app list after being installed. Also I can’t install them again. And I can’t uninstall them either. The apps are: group , sets and better logic. All three I can’t find on my homey but when I try to install them again. I get the message the app is already Installed. Using 2.1.2. Rebooted multiple times after install.

Hmm, i miss one?

Where do u get this message? If it’s just the “installed” button in the app-store then u can click it again.

Do you mean you can’t find them on the App Settings page? Are they shown here?

I noticed your screenshot is from the developer side of the homey, is that a dependency for those three apps? (I edited my original post so people can read the third app)

The third is the group app, I corrected my original post.

The message that the app is already installed I get when pressing the install button in the “app store” on the homey website. But also if I go to add a device and search for group and want to add a group it says the app is not installed and if I want to install it. When I press yes, I get the message it’s already installed.

No, it’s not a dependency, you should also be able to view the app settings in the mobile app (“Meer > Apps > Better Logic”, for instance):

There, you can configure the app.

To enhance my explanation :blush:

There must be some kind of bug then. I get the same message when trying to install a new app of which i am sure it was never installed before. Can also tell u the app WILL install anyway.

So are you saying I just have to be patient because it will install eventually? Because that’s going to be hard for me, patient is no where near my middle name :joy:

I have seen this happen…
I have seen it when I tried multiple app installs without being patient… and I have seen it when my internet connection is funky…

A reboot of my router killed the connection to homey which to seemed to make the app store stop trying to install the app…
a reboot of homey then allowed me to install 1 at a time

I will try this. I did add a couple of apps in a short time.

In my case, neither applies and I also get the same message.

Ah… I was speaking from experience…

Yes there is clearly an issue with the app store cause I just got it with an app I never had before

Yes, after testing I can confirm the appstore is not working.
Is there any way of communicating this to Athom? @Emile @Bram @MatthewWaanders @Stefan @Kars @JeroenVollenbrock @Boaz :grinning:
I like to be thorough, besides being impatient…

yes… you need to email

I’ve send them an email. Their probably going to hate me for all the communication and mentions here :rofl: Since it’s a national holiday today in The Netherlands…

1 Like

@Emile, @Bram, @MatthewWaanders, @Stefan, @Kars, @JeroenVollenbrock, @Boaz I guess taking a holiday is more important then fixing your customers experience and uptime of your server?

Maybe it’s time for a mirror of your server maintained by the community? So if you’re all taking your time, your customers can just go on with their stuff. In other words I’m saying: if you don’t want to take responsibility for your shortcomings maybe you should outsource them… That way you might and up with happy customers instead of disapointed ones.

Update: After a DM to all available Athom employees on Slack I got some contact.
Hi Frits,
Could you please tell me the last app you tried to install, that failed?
Could you please check the signal strength of your WiFi at the position of your Homey? I see indicators in your log that might point towards a weak internet connection.
If the WiFi signal is strong on the location of your Homey, I suggest you perform a factory reset of your Homey, to re-install the firmware. Since your Homey is still new, this should be an easy fix.
Please inform me about the results.
Best Regards,

My reaction to him was:
Dear Boaz,
Can you tell me were I can see what the signal strength of the Homey’s wifi is? Because none of my devices in my house have weak signal strength, not near the Homey, not in other places.
That way I can check the signal myself and test different settings and locations.
A factory reset should not ever be the solution to this problem. If you think it is, it’s a BIG nogo for me and I will immediately return the Homey to the store.
Kind regards,

Update from my side again. I solved the problem!!!
After some tips and pointers of Emile on Slack this weekend I did some testing with another network and it worked. So it had to be my network. And it was. Apparently I had an NTP server running on my Mikrotik router which wasn’t really doing a good job. Disabled it and the problem was gone.

So long story short: Connection problems tend to have this message as a result in the app store.

So I miss the say sorry post. Tagging all Athom guys and being ur own fault? C’mon, be a Man!

1 Like