[APP][Pro] X10 App

The CM15pro transmits all received RF commands to the powerline
It does not send received powerline commands to RF.

So indeed you need to create a macro to “forward” the signals to RF

Hi Frank, thanks for your answer, I was afraid it would be like that.
I will have to use standard RF transceivers (RF wall switches, etc.) to get my triggers into Homey, not a big probleem it concerns just 2 logic signals.


@nattelip, at the top of this topic is “wont work in v2 for the time being”. Do you mean that you are trying to make the app compatible for Homey V2? I can now use the existing x10 divices, but can not add new ones.

Theres also the remark above, but I do not dare to conclude that the “v2 version app” is stable for the new homey v2 firmware
@nattelip can you comfirm the last release of this app is stable for the new v2 homey firmware?

No the X10 app is not ready yet for V2 , the way i use custom pairing the devices ,must be sligtly recoded for V2 , this wasnt known until V2 emerged, and the answer to the pairing problem i just got 3 days ago and is also updated in the developers docs . but a solution will be worked on soon. i dont know if the x10 app survives upgrading from v1 to v2. my homey crashed and had
completely be resetted going to v2 . so all devices must be paired again and that is not yet possible. that is also the case for the rfxcom.2 app. if your x10 app survives the upgrading to v2 it should work. but i cant confirm it. on my v2 homey the app installs and lives but i cant pair yet

you could read the first thick sentence of this thread ?

i did, but you confused me by using “v2” in two ways in this post.
I understand now that “v2” in the thick sentence is refering to v2 of the homey firmware. And “v2” used in “v2 version” is refering to your app and is unrelated to the v2 homey firmware

no , v2 is and v2 means the same only on the time the v2 version of the app release it wasnt known that the v2 firmware demanded al lot more change in code as was communicated by athom before the release of the v2 firmware, that was not expected.t So i put not V2 compatible for the time being above the thread, to warn the users. A lot more has to changed and chould be changed in the code to let it work with v2

Thanks for your reply!
I will patienly wait with upgrading to homey 2.0 until the X10 app works.
Still have a lot of X10 that works perfectly fine.
So will not risk X10 not working.

Appreciate the work you do
(wish I could program my own stuff in homey apps…, one of the things i would like to dive into this year. Would like homey to read out my RF PIRs from my alarm system. So In can use them in flows…

Gr Frank


committed the v2 version to github, waiting for approval trhen you can pair again.


Update Version v2.07 installed an hour ago on my Homey 2.0.
I have setup my X10 devices and tested a few flows and it works perfectly.
Thanks very much for your efforts to make this work again on homey 2.0!

Hi after the update to 2.0.7 my x10 app stop working :confused:

If I try to turn on and off a light it will work very random

I have experienced no problems at all. I use it for my curtains though and not for lights but that should not make any difference. The distance between my homey and my X10 TM13g transceiver is about 6 meters and it picks up all signals flawlessly. Have you tried restarting homey and the x10 app yet?

I have tried to reinstall, restart and the same result. The 2.0.6 worked fine. I have 1 meter to the TM13G transceiver. Is it possible for me to go back to 2.0.6?

@Mats_Grano was this issue solved for you? I am still at v2.06, thinking about upgrading to v2.07. But I need X10 to work (and its working fine now)

@Mats_Grano did you get X10 working again?
Planning to upgrade to 2.07 (but cannot affort to have it stop working…)

Hi There,

Got some of DS10 door/window sensor, may they works? I tried to include device but not sure the right way to do that, selecting device (all) then click next then got gear window and nothing happens, what’s the correct way to include device?

That sensor works with the x10 security protocol and that is not implemented in the app, I don’t have any x10 material with that protocol

@nattelip: Looking at the V5.0 posts in the forum. I think X10 is not impacted by V5.0 right?
No zigbee and its based on SDK2 now…