[APP][Pro] Tesla Smart Charger

Hi. I recently updated the app to the latest version and I am experiencing some issues with the charge plan. For example today I connected the charger at 20:26 and the charge plan that were created starts at 19:00. This doesn’t happen every time. I’ve tried to restart homey and the app.

This started happening after two things happened:

  1. I updated my flow with new cards to set the % of desired battery level
  2. The car software was upgraded

So it is hard for me to conclude which one is at flaw, but it is clear that it’s not working as intended.

I have removed all logic that sets the charge limit %, but the behaviour is unchanged; the car charges to 100%.

I will try to disable all my flows in homey when I get home from work, and just let the car be plugged in with a max level set. This way I’ll verify whether it is the car alone that is the cause of this behaviour or in combo with the otherwise great Homey app :wink:

I have multiple flows for charging the car. I have one flow that determines whether to start charging or not, and one flow to execute the start charging. This last one is what you see below:

I am wondering if the issue could be related to the “Set charge limit mode to Max range”?

OK, I’ve found the issue.

I can confirm that it is not the Tesla app nor the car itself that does this. I verified this by disabling all flows in Homey and charging normally. The charging stopped at the given % State of Charge -both at home and at work.

So I reenabled the flows, and the behaviour started again. I verified that when the card “Set charge limit mode to” was set to “Max range”, the charge limit pops up to 100%. Changing this to “Set charge limit mode to Standard” solves the issue and the charge limit stays put.

I guess it makes somewhat sense, but the current documentation on this and other topics makes it a bit hard to fully understand the consequences of the choice I make with various card. Some topics are covered OK, but others are not so much.

I’d be happy to contribute to documenting, if you have a github repo or something @balmli .

@FrodeFalkfjell @leppen do you use the “Set charge limit mode” card?

Nope. And when I disable all flows (or disable the Homey app), the cars starts charging all the time anyway.

I made a test with the Tesla app: I enabled Scheduled charging, set to 00:00. I set the Charge Mode to Off in the Homey app.
=> Charging doesn’t start all the time. It’s quiet, and starts at 00:00. So in my case, it seems Tesla is doing something to trigger the charging, not the Homey app.

No i do not