[App][Pro] Tasmota MQTT

The beta/test version of the MQTT Hub does actually provide the ability to import mqtt devices to Homey. Both by auto discovery as by manually adding MQTT devices. This is implemented by mapping mqtt topics to Homey device capabilities.
The limitation for now, is the topic values need to by primitive types. Using json (path) to select a value is not supported (yet)…

1 Like

Oh, so it was in beta version. I remember I saw it somewhere. Anyway will not work with tasmota’s json values.
P.S. Thanks for MQTT Hub grate application, using it to import devices to MQTT and then with my own Python script export data to Prometheus for Grafana. Works like a charm.

What firmware is required on the tasmota devices?
I cannot get the app to find my Sonoff-Tasmota 6.4.1 devices.
only get timeout error.

I use MQTT Client and broker by Menno van Grinsven.
And I can see the sonof devices in the broker using MQTT Explorer.

Anyone have any suggestion on what I can have done wrong ?

edit

For good measure I upgraded one of my devices to Tasmota 8.1.0, still no luck getting the app to find my device. :confused:

Application should support any version of Tasmota.
The only explanation I can get is topics. For now Tasmota MQTT uses “cmnd” topic to send commands and “stat” topic to get devices statuses. You should configure your device to use that topics same way as in default MQTT configuration. So your device should be configured like this:
Configuration > Configure MQTT > Full Topic > %prefix%/%topic%/
It is default value.
I have plans to support any topic but it will require some work so will not happen soon.

Turn off autodiscovery for Home Assistant and revert the topic structure like pavlo says. And yes, you will have to add your devices manually to Home Assist

I did have the default settings as you describe because I saw you mentioning that to someone else above.
I have been fiddling with Home Assistant in the past so I resetted a device to test.

None of the above was the problem.

I suspected the MQTT client or a correlation between “Tasmota MQTT” app.

I reinstalled both of them and after that it worked !
No idea why but in a future version of “Tasmota MQTT” it would be nice to have a visible log or something like “test connection” thingie.
Even if MQTT client is not installed the Tasmota MQTT app says that no new devices was found.

Thanks for your time and app !
I’ll try to asimilate the rest of my devices now :slight_smile:

@PascalB Thanks for help.
I am not using homey assistant so I have no idea what topics used by Tasmota device configured from HA. Can somebody check it and post names of topics for commands and statuses please? It will be easier to add this topics than to add universal search for devices.

The thing is, when using autodiscovery for Home Assistant in Tasmota via SetOption 19, Tasmota switches the MQTT topic structure to topic/prefix instead of regular prefix/topic. This can result in problems when using your app I think?

1 Like

Hi everybody,
At last, I managed to finalize some changes. I published version 4.5 to beta, you can find it here Tasmota MQTT beta. First of all:

Warning: Because of tricked I used to make multisocket devices work with onoff capability beta version change capabilities for existing devices so if you will install the beta and then roll back to the stable version you will need to delete all devices and install them again.

So what is new:

  1. Now works with devices configured for Home Assistant (through SetOption19) Thanks @PascalB
  2. Works with flow card “turn off all devices”
  3. Should work with Google assistant (can somebody confirm pls?)

Also, keep in mind that multisocket devices now behave a little bit differently.
The whole device is marked as turned on if any of its sockets turned on and turned off if all sockets turned off. If the device is turned off and you click on it in homey GUI all sockets of the device will be turned on and the opposite if it is turned on and you click all sockets will be turned off. Also should be similar behavior with Google assistant if you turn the device off it will turn off all sockets.

P.S. Will keep version 4.5 in beta for at least a week. If you will have bug reports or suggestions don’t hesitate to write here.

Hi, I can’t connect to my sonoff mini with the tasmota firmware. The procedure failed. In the MQTT (host) window, you must indicate the IP of my Homey Athom box or something else. In the Android Homey application, I installed the MQTT broker, with port 1883, it launches but tells me that it has disconnected from the client. when I install the GénéricTasmota application, the application expires. I put the IP of my Homey box in the Sonoff application. What to do ? Thank you for your help.
I restarted (smoothly) the device you want to publish
then the installation stops

First of all try to connect to your broker from your PC with client to see if your Sonoff configured properly to connect to broker. Also you MQTT client application should be installed on Homey and configured to communicate with broker. In opposite case Tasmota MQTT application will not work.

Hello,

Attached are screenshots of the different stages which I access. Maybe there are errors? cordially

Hi @pavlo,
Great app! Thanks for your work. It is easy to add a Tasmota device this way (as it should be :stuck_out_tongue_winking_eye:). Great you fixed the SetOption19 “problem” in the beta, I was searching what my problem was untill @PascalB mentioned it.
Wil you be adding more to the app in the future? Like the possibility to add all the sensors and buttons that Tasmota supports? I am asking just to know, not to rush you. It is one thing I am missing in homey.

greetings

@Lionel I can see from your screenshot that you are using ITEAD Sonoff application to add a device. Mine application is Tasmota MQTT.

@SilverApe You are welcome. I can’t promise anything. Just got today mine sonoff light bulb and led strip so next features to support are dim and color.
Sensors and buttons are a very general topic so it will be not easy to support them. Anyway, I would like to try to add them in the future but it will not happen in the next couple of months.

Good evening, I tested the application, it does not find any device which is not set correctly?
Lionel

Sorry, doesn’t work.
However I didn’t delete and re-added the device. Should I do that?

@pavlo
I understand, those things should be 1st on your list. Those are basic things useful for everybody. Sensors and buttons are for a select couple. :+1:

@Lionel Are you sure you are using the Tasmota MQTT application not the Itead sonoff application? If yes can you please post here log from MQTT client application.

@Robin_van_Kekem Sorry for the stupid question but are you sure that you tried beta? Because I can see how many people installed beta application and the number is still 0. If you want to install beta you should use this link: https://homey.app/nl-nl/app/com.paveld.tasmota/Tasmota-MQTT/test/
You should check version of application in Homey app. Stable version is 4.0, beta - 4.5

@SilverApe Will see what I can do. Can you meanwhile post me some examples of sensors and buttons with Tasmota support? I just never used any of them before. I will need to order some, and with all this virus situation it will take months to be delivered from China. So better to do it now.

@pavlo
I have ordered these (and more :wink:)




There are way more, I will see if I can find a list.

As for the waiting, I am still receiving my orders on time. Maybe some orders take a long time, but some don’t. I haven’t had any delays.

Here is the list: https://docs.google.com/spreadsheets/d/e/2PACX-1vRBFqaP5QAFmT8iIYBxrn-EQp7-SrkxL6tb0OjpqtBxDEsmkiWCFei3sFyA_UXoqlbs3CqtEdOfC6Pa/pubhtml?gid=1029939700&single=true

Just installed the beta and can confirm that the behaviour of the added device is now as a light when configured as such. So in Homey flows this now works. Also, Google home sees the lights. Great work!

Looking forward to dimming and other progress! :grimacing: