[APP][Pro] NodOn - Z-Wave devices (Stable: v3.0.1, Test: v3.0.3)

Here is from button 1:

2020-12-08T20:31:06.581Z Node[29]: Received application command for COMMAND_CLASS_BASIC, data: 0x01ff
2020-12-08T20:31:06.581Z Node[29]: [COMMAND_CLASS_BASIC] {“Value (Raw)”:{“type”:“Buffer”,“data”:[255]},“Value”:255}
2020-12-08T20:31:07.775Z Node[29]: Received application command for COMMAND_CLASS_WAKE_UP, data: 0x07
2020-12-08T20:31:07.776Z Node[29]: [COMMAND_CLASS_WAKE_UP] {}
2020-12-08T20:31:07.777Z Node[29]: Marked as online
2020-12-08T20:31:07.788Z Node[29]: [COMMAND_CLASS_BATTERY] [BATTERY_GET] {“type”:“Buffer”,“data”:}
2020-12-08T20:31:11.277Z Node[29]: [COMMAND_CLASS_WAKE_UP] [WAKE_UP_NO_MORE_INFORMATION] {“type”:“Buffer”,“data”:}
2020-12-08T20:31:11.277Z Node[29]: sendData to COMMAND_CLASS_WAKE_UP, params 0x08
2020-12-08T20:31:11.278Z Command[949] start: sendData
2020-12-08T20:31:11.279Z ProcessSendData[612]: To node: 29 with data: 0x8408 and txOptions: AUTO_ROUTE,ACK,EXPLORE
2020-12-08T20:31:11.305Z Command[949] end: sendData
2020-12-08T20:31:11.305Z Node[29]: Marked as offline

And here is button 3 :smiley:

020-12-08T20:32:11.995Z Node[29]: Received application command for COMMAND_CLASS_BASIC, data: 0x0100
2020-12-08T20:32:11.995Z Node[29]: [COMMAND_CLASS_BASIC] {“Value (Raw)”:{“type”:“Buffer”,“data”:[0]},“Value”:0}
2020-12-08T20:32:13.190Z Node[29]: Received application command for COMMAND_CLASS_WAKE_UP, data: 0x07
2020-12-08T20:32:13.190Z Node[29]: [COMMAND_CLASS_WAKE_UP] {}
2020-12-08T20:32:13.192Z Node[29]: Marked as online
2020-12-08T20:32:13.202Z Node[29]: [COMMAND_CLASS_BATTERY] [BATTERY_GET] {“type”:“Buffer”,“data”:}
2020-12-08T20:32:16.692Z Node[29]: [COMMAND_CLASS_WAKE_UP] [WAKE_UP_NO_MORE_INFORMATION] {“type”:“Buffer”,“data”:}
2020-12-08T20:32:16.692Z Node[29]: sendData to COMMAND_CLASS_WAKE_UP, params 0x08
2020-12-08T20:32:16.693Z Command[950] start: sendData
2020-12-08T20:32:16.694Z ProcessSendData[613]: To node: 29 with data: 0x8408 and txOptions: AUTO_ROUTE,ACK,EXPLORE
2020-12-08T20:32:16.797Z Command[950] end: sendData
2020-12-08T20:32:16.798Z Node[29]: Marked as offline

I only see the command class basic come in, so the scene option has not been passed on to the remote properly, but most likely is still stuck in one of the other options.

try changing it to one of the other values, save the settings (no need to wake up the remote), then change it back to the scene, and at the time you press the save button also press a button of the remote.

EDIT: do do this close to Homey, distance makes it too prone to failure.

1 Like

Thank you very much. That was the problem.

Need to try to learn more about logs, and what they are telling.

With my softremote i cant get a battery status only ?

I’m not sure what you mean with this question, could you explain it more detailed?

The soft remote works fine. But I can’t get a readout from the battery. No information about the battery status. ( full empty of battery %) i only see a questionmark. So when I touch the battery logo I get a ?

Hmm, never seen that before with a NodOn device (at least in the past 3 years).
What is your Homey version?
What is the distance to Homey?
Was it like this ever since you included it into Homey, or after a while, like after an update?
Do you have more z-wave devices?

I got this from the start of inclusion. I have V5 but it was also on the previous version. I have a lot oF zwave on all the 3 floors. The softremote is on the second floor. Homey is downstairs. The zwave range is good. The next zwave router is 2 meters further. In developer i can see it is connected to that router

Any idea how to solve?

Sorry for the late reply.
so i’ve been trying to research (while doing a rewrite to SDKv3) how it works exactly again (when the battery level is retrieved), and this is occasionally send when you press a button (once every 4/5 presses).

But if it isn’t send by your remote it is hard to say, could you send me a log (homey app → more… → apps → nodon → settings (cog wheel) → send log) after having pressed a few buttons once in a while.
If it doesn’t wake up, or just doesn’t send the battery level, the only option might be to re-include the remote, but before doing that, lets see if what the log will say anything.

Ok not home now try tomorro thanks. Keep you informed!!

Done and sent PM

I’ve seen your message and log, unfortunately I don’t see anything strange in your log, the battery level is correctly asked of the device.

So the only option I can give you is to try and re-include your remote, and see if that fixes it, unfortunately that would also mean you’ll have to fix any flows.

1 Like

Ok thanks. Yess there are som flows but will fix that. Later i will ex en incl the remote and will post my exp. Thanks for looking !!

Its working thanks!!

1 Like

A new test version is live!
Have tested it very thoroughly, but i’m still human, so if you find any bugs just let me know, then i will fix them as fast as possible.

v3.0.0 (test):

  • Re-write to SDKv3
  • Additional changes:
    • Changed the “hold” trigger to every second, instead of +/-5 times a second to keep Homey from disabling that flow card immediately
    • Updated all icons to be more clear
    • Added a Reset Meter maintenance action
    • Updated all images to make them more consistent
    • Minor stability improvements

my 2 soft remote’s don’t work anymore, i removed the successfully from homey, but i am not able to add them again… just nothing happens adding…

Replace the batteries (yes even if they still said 100% in Homey and green on the remote itself)

I removed everything, als the app, installed it again, restart homey and now everything is working again!