[App][Pro] myStrom - Smart Home

myStrom - Smart Home app for Homey

Adds support for myStrom devices.



  • If you have problems after the upgrade, register all devices new.

  • Finding new devices can take up to 4 minutes.

  • To add myStrom devices, you have to use the myStrom-App at the moment.

  • Each device must have a fixed IP address.

  • Diagnostic-Reports which are not requested by me will be deleted automatically …Community first

Important note for Buttons:

Keep in mind that in order for the Button or Button+ to respond to any of these requests they have to be in the configuration mode:

  • Button: (Re-)Connect the button to a power source with the provided USB cable. Press the button and after some time it should become visible in the network.
  • Button+: Open the back of the button by rotating it clockwise. Remove the batteries and reinsert them. The Button+ should now be visible.


  • myStrom Switch v1 & v2
  • myStrom Switch Zero
  • myStrom Switch EU
  • myStrom Bulb
  • myStrom Button
  • myStrom Button Plus
  • myStrom LED Strip
  • myStrom WiFi Motion Sensor


  • Add homey discovery-api
  • Test WPS-Mode
  • Adding devices (pair) to WLAN without myStrom-app

Copyright and license

Copyright 2017, 2019 cFlat-inc.org under ISC License

1 Like

Changelog (entire)

Live: v1.2.10

  • Bump myHomey


Hi Chris

First of all thank you for your app.
Will it be possible in the future, to use the Wifi Switch temperature sensor as a trigger?
E.g. to display the temperature under devices or to include the temperature change in a flow?

Guete Morge,

Please report a request or issues via Github

Sure no problem, but not today or tomorrow, I’m busy right now :slightly_frowning_face:.

THX Chris

Hi Chris

I just bought a myStrom WiFi Button +. It was possible to add the button+ to homey, sadly my homey flow with “Button gedrückt - kurz gedrückt” doesn’t work and I don’t see any “Geräteverlauf”. I’ve also tried other Button types, but no reaction at all. Any hints what I’m doing wrong?

The Button has Firmware 2.74 and 100% battery power :slight_smile: . The Homey myStrom App has v1.0.2

Cheers Josef

I’m trying to locate the problem. :worried: !!

New version relased:

  • Fixed Button
  • Add batteries type

Because of the new certification process unfortunately it took a little bit longer until the new version went live, sorry :roll_eyes:

Hoi Chris

Thanks a lot, I’ve already seen your github commits a few days ago and couldn’t expect your new version, now I got it. Seems to be perfect now, thanks a lot for fixing. I will now try to find someone who 3D prints a cool case for the + button :wink:.

Merci vielmal, Cheers

BDW: For the next time, you can install the test version (myStrom-SmartHome App for Homey | Homey) :wink:

I am interested to use this button for easy on/off home alarm when going to sleep.

Will the button or button + stay with lights on when in “on” state ?
Is the light customizable ?

Overall getting the flow cards that I can use would be helpful.

For example of I could make it have a color on touch (red alarm on, green alarm off) and a toggle on pressing twice or holding would work also.


In short, No, there is currently no API :frowning_face:

Hi there, any news when the myStrom WiFi Motion Sensor will be supported?
Os have i missed that and it is already working?

There is no planning regarding the sensor, Sorry :no_mouth:

Hi cgHome,

First of all, many thanks for this app who makes me happy with the myStrom switch. I used since more than 1 years without any issue. :smiley:

But since yesterday, i tried to pair a myStrom bulb without any success… i still have the message “No new devices have been found”. Of course, the bulb is configured by the myStrom app and working good from this one. The firmware is at its last version.

I tried to unpair from myStrom app, and reset it by switching it 5x. I remapped it and try one more time from Homey to pair it, but still without success…

I need some help for that.
I didn’t remember i had problem with the switch…

Maybe it’s due to the V5 of Homey ? I saw on github that you’re at the version V1.1.0 instead of 1.0.6 on Homey. Migration to new wifi driver, maybe it’s the solution ?

Why this version is not on homey that now Homey V5 is stable and not anymore in beta ???

Many thanks for your help

Best regards

Kevin Joss

Hallo Chris

In meiner MyStrom App habe ich 16 Plugs - Homey App findet aber nur 6 :frowning:
woran könnte das liegen?
was könnte ich tun?
Vielen Dank für Deine Hilfe!


Unfortunately, I have no idea, because I do not have a clairvoyant crystal ball.

Could you please tell me the Homey version, the My-Strom App version, version of the plug (V1 od V2), the firmware version, etc.?


PS: Please write in here in English so everyone can understand, if you can’t, use deepL.com to translate.

Hi Chris

What a pity that you don’t have a clairvoyant crystal ball, life would be much easier… :wink:
I am not very good in tech-things, so please forgive me my to short question…

I have:
MyStrom Version 5.5.1
plugs with and without temperature, I guess this is the difference between v1 and v2?
all v1 (firmware : 2.68.10) are visible in homey
no v2 (firmware: 4.0.4) is visible in homey

homey Pro (Early 2019): vers. 8.0.5

Why the v2 are not visible?

After several attempts to reproduce the error and consultation with myStrom, I can “officially” tell you that the firmware version 4.0.4 with the current Homey myStrom app (v1.10) works fine and you can add the switch after deleting again without problems and find.

The only thing I noticed is that Homey does not always show the new device, so if you miss a switch, then restart the Homey app or press the refresh button on the web app.

Gruss Chris

Thanks a lot for trying to help!

Unfortunately it does not work.
I even reset the plug in mystrom and connected once more.

in homey always the same message:

 Es wurden keine neuen Geräte gefunden.


You are looking in the wrong place, because this message says that the switch is installed.

If you press the app icon in the IOS/Android app where you have installed the myStrom app, you will see an overview of all installed devices. You should be able to find the switch there