[App][Pro] MCOHome App (v1.5.4)

You probably have a second account where you Homey is connected.

I have got life in to it by logging out of both instances, closing the browser and then logging in again. Thanks for your help, it is much appreciated

I’ve just released v1.5.2 to the test environment of the app store: MCOHome | Homey

This release is based on SDK3 (compatible with Homey Pro (Early 2023)) and adds support for the MH8-FC4 and C421 shutter panel.

Since I don’t have all MCOhome devices, I could not test all devices. Please report back if issues arrise.

3 Likes

Hey

Any news on the released v1.5.2 test ? unfortunately I can’t test it yet as my Homey Pro doesn’t arrive till February - all my light switches in the house are MCO Home so would be able to test fully

I had some issues with my MH7H Thermostat and the v1.5.2 test version. But @TedTolboom fixed them really quick and they work now with no issues with the v1.5.4 test version.

Actually there is no reported issue on GitHub with light switches, so I guess they will work But of course I don’t know, if someone who is using MCO switches has already updated the app.

Thanks for the info

Hi @TedTolboom ,
Any chance the non-neutral 2 Gang switch, MH-S312-SL, will be supported soon?

Thanks!

The MH8-FC4 thermostat added as basic z-wave device, i tried twice and i got the same result.

which Z-wave ID’s are shown in advanced settings when added as a basic Z-wave device?

I have spare piece of thermostat that i cant send to you.

Hi @TedTolboom ,
Just installed a non-neutral 2 Gang switch, the MH-S312-SL and was not recognised.

Product Type ID is the same as the neutral version, 12578. But it’s have a new Product ID 28930.

Appreciate if you can add the support.

Thanks!

Regards,
Justin

Z-Wave Device Information

Device ID
104

Manufacturer ID
351

Product Type ID
12578

Product ID
28930

Firmware Version
1

Firmware Sub Version
5

Firmware ID
29442

Hardware Version
1

Device Class (Basic) BASIC_TYPE_ROUTING_SLA…

Device Class (Generic) GENERIC_TYPE_SWITCH_.

Device Class (Specific) SPECIFIC_TYPE_NOT_US…

Hi @TedTolboom,

After I’ve moved to HP23, I’m getting the message “TRANSMIT_COMPLETE_NO_ACK” when toggling my MCOHome touch panel switches. eg. toggling a switch via app, toggles on/off the switch successfully, but then I get the message “TRANSMIT_COMPLETE_NO_ACK”, and the status revert to the last status on the app.

Anyone encountered this? Any advice?

Thanks!

regards,
Justin

Hello @DirkG,

is there a solution to this problem meanwhile? I have 10 MH7-WH and it really sucks to adjust time on them manually every two weeks (because by then 2 of them are running min, 3min ahead of time)

No, unfortunately not. Changing the time using Z-Wave raw configuration is not possible in my opinion. But I have just written an email to MCO.

I simply can’t get my MCOHome switches functioning properly on my Homey Pro 2023.

I keep getting TRANSMIT_COMPLETE_NO_ACK for almost all of them. Even those that’s like 3 meters away.

Have tried resetting zwave network, factory resetting Homey, but still no go.

Is there a “correct” way to include the switches for Homey Pro 2023?

It’s been frustrating when the most basic of HA is not working properly for me.

Any advice is very much appreciated.

Have you tried factory reset the MCOSwitch ? Note different hw version of MCO switches may have their factory reset steps differently (read your manual) even though it a same model. Ensure devices already factory reset before include it.

I have been migrated all my MCO switches to HP2023 without any issue except two switches that spoilt weeks ago. I took a fair bit of time doing inclusion but failed, thereafter a few factory reset on the device then able to do the inclusion.

HP2023 setup I do not have a repeater and signal are much better, comparing with HP2019 I still need to run two z-wave repeaters.

I tried again, factory resetting by the switches (mine requires pressing a switch 20x). But I’m still facing the problem.

I can include the switches just fine, but thereafter, I’m getting those “TRANSMIT_COMPLETE_NO_ACK” messages. Even for switches as closes as 3meters away.

I’ve no issue with Zigbee devices though.

Wondering if my HP23 came with faulty z-wave?

Since your issue persisted hope you submit issue ticket to Athom let them looking to your HP2023.

Thanks. I did just that. Hope I didn’t get a lemon and they can help fix it.