[APP][Pro] Heatit Controls app [v3.6.5]

Yes

Hi Nannes,

It seems this functionality has slipped passed our testing during development.
The function is unfortunately not implemented in our Heatit Controls App within Homey, but will be included in the next revision of our App.

I see there is a case in our ticket system regarding this, I assume this will be where the case will continue.

Thank you!
Then I will wait for it :slight_smile:

Hi!
I was wondering if the “up/down” buttons on Z-trm3 have any updates/triggers towards Homey?

F.ex. if I use Tibber or another system to activate them in terms of electricity costs, I was wondering if I might be able to use a variable or a virtual device to be controlled, so that if I change the value on the actual thermostat screen up/down, I’d like to update a variable in Homey with that value, which can tell a virtual device that my “target temperature” has been changed, rather than Tibber just changing the value back at the next trigger from them.

In short - I’m trying to create a “relative” temperature that can be controlled by up/down on the LCD on z-trm3.

Also, I was wondering what the effective security issues is by not using S2 when adding the device? Is it basically that 1 minute while including the device that makes it unsecured, or will it always be “unsecured” if added with 00000?

Thanks!

Hi, There is no trigger for the press of buttons on the thermostat.
And any device added with “00000” will always be “unsecured”. The 00000 code is to force unsecure.

Thanks for the reply.
But there is a trigger for the target value being changed. Is that regardless of being changed externally or from the buttons?

What I’m trying to do, is to have automation from Tibber, but I want to be able to set the target temperature from the buttons. I could of course just not use automation from Tibber, but rather set it up locally on Homey, but I’m curious if I’m able to use virtual thermostats and variables with an offset to administrate the HeatIt Thermostat. Basically it has nothing to do with HeatIt directly, rather me wanting to have the option to control locally as well as getting cheap electricity.

The problem is that some of the devices has a wrong ID, and will need to be re-flashed to get the proper ID.
Heatit can’t add the wrong ID to the app, because then they would use an ID that doesn’t belong to them.

Why does some devices need to use “Homey” instead of your app? What are the differences?
Does this mean that the HeatIt app is no longer using S2 for inclusion at all?

If so; Is it a temporary issue workaround, or will HeatIt support S2 in the future?

Hi, sometime my Heatit z-dim turns the light off just some seconds after it have turned on. as you can se from the log its turn on by a flow. (sone active) and turned off by "heatit controls right after.

I have Homey Pro 2023. and App V3.4.2.

Somethimes its working as it shold also. This is from the same day (today)
Turned on and off by sone activity / inactivity

hello, I have problem add my z-smoke detector 230V to my new homey. see my screenshot. Anybody can help me please? adding to old homey model was no problem. thank you

1 Like

Happens to my single relay too. Got both green dots, and then something went wrong. Have heard that others also have the same problem on early 2023. Goes straigth in on my old 2016

and what shall we do? send this message to heatit homey developer? or buy old version homey? :slight_smile:

Hi!
I’ve got a Heatit Z-Relay 25A recently and was trying to make it work with my Homey. It seems to be recognized correctly, but it doesn’t report power, current and voltage to Homey, however. I tried both secure and unsecure connection, didn’t help. Only Energy meter works

When I paired the same relay with my old z-wave.me RaZberry controller, everything works there, so the problem is in Homey or an App


Did you use the z-dim on another zwave controller earlier? If so, test a factory reset and add it again. I had a similar issue. Used it with home assistant and added it to homey.

Hi, I have a lot of Z-DIM, but got my first Z-DIM2 today. I can’t include it however. I have recently migrated to Homey 2023. I have not tested the Z-DIM2 against that old Homey model (not in use anymore).

I tried both from distance and keeping the Homey as close as I could. Any tips? Like adding secure vs not secure? (I don’t know how to change this, if possible).


@HeatitControlsAB Update: I have tested the Z-Relay for a long time with security off. It’s not great that the secure connection isn’t working, but it does seem stable over time with security off. I had it mounted to control my water heater again, but this time with a bypass switch. So if it fails again, I can bypass it without calling an electrician yet again. I have set the group association to 1.1 on group 1 and left the rest blank, as recommended. Firmware version is still 0.12 as I have no way of upgrading it.

I have attached two temperature sensors for sensor 1 and 2, and set them to report every 60 seconds. They do report seemingly correct temperatures - but only when I restart the Heatit app in Homey! After that, no updates, until the next time I restart the Heatit app. However, in Homey it is possible to make a Flow that restarts Heatit every 5 minutes. With this workaround hack I do get regular temperature readings.

It does not report any sensor data on power, voltage or current. I have set the device load to 0 W, as I understand this should make it report the actual measured power. Is that correct? But it sends no reports at all. If I set the device load to e.g. 2000 W, I also get no reports. The interval is set to 60 seconds. This is the only thing I miss now (other than S2 security, of course).

Thanks

Hi,

How far away are you from the Homey when you are trying to include?
How many devices are there in your gateway?

Non secure (which our app uses) is faster for inclusion than security.

Hello,

This is also what we have seen and have therefore chosen to not use security on our Homey app.
Please try setting the associations as follows:
image

1 Like