[APP][Pro] Heatit Controls app [v3.6.5]

Thank you for supporting your products for Homey users! It seems I just haven’t understood what the associations mean. I set them as you recommended, and disabled my workaround flow. Now I get smooth temperature readings, and also power data. I get nothing for voltage and current, but I don’t need them anyway. Thanks!

This is more so an issue with how the associations are built up in the device.
Voltage and current are reported, but aren’t registered in the Homey, we are looking into if this could be something with our App.

1 Like

With help from Heatit I finally got the Z-Relay working properly with my water boiler. I use the price info from Tibber to turn the heater on when the price is cheap, relative to the price level on that day, and off when it’s expensive.

I also have two temperature sensors connected. One taped to the hottest accessible part of the boiler, another sensing the air temperature of the room, since the room temp can affect the outside temp of the boiler. Once I’ve gathered enough data from them, I can make flows that turn the boiler on if it gets too cold. This could happen if the price is consistently high for a long while.

This flexibility makes the Z-Relay great for boiler duty, now that the problems are resolved. It also has input for a flood sensor, which I might hook up at some point as well.

1 Like

Hi, as I wrote I tested both from distance (without moving the gateway) and moving the gateway so I could have it touch the switch when trying to include, without success.
I have Homey 2023 with approx 60 devices.
18 of the devices is with the Heatit app.

I’ve added several Z-TRM3 to my network, and seems to work fine. All have the same FW listed.

But the latest one I added has some very strange values reported for both voltage and wattage:

What could be wrong?

I tried excluding and re-including without any luck.

I then tried excluding, turn the breaker off, rebooting Homey and then turn the breaker on and include again.

It failed to be added the first time, retried, and now it’s added and metrics seems to be correct.


I have 8 Heatit Z-TRM3 thermostats at home and use them to control my underfloor heating per room.

It is also possible to deactivate the relay in the trm3 so that it does not switch every time there is or is not a heat request in the room.

And what is the difference in heatit app between the on and off button and heating and off, both completely turn off my thermostat.

For people looking for Heatit thermostats; I am selling five Z-TEMP2 thermostats (4 black, 1 white) since i’ve changed the heating system. I’m not asking much (€160) because i’d like to see them have a good home in our community. Send me a PM for more info.

I’m having issues with one of my Z-TRM3.
It’s the “oldest” of the ones I have, but still probably from late 2021.

When I reset it, it did say “4.2” before showing “A”, so I guess that’s the firmware version.

Every HeatIt device I have have been included smoothly, including the Z-DIM2 and 4-button panel above it.

But for some reason, I cannot get this exact thermostat to include. It always ends with “Err” and nothing happening in the app.



Things I’ve tried so far:

  • Add through HeatIt app
  • Add through Homey App
  • Pull breaker
  • Reset (center + right for 20 seconds)
  • Restarting Homey Pro 2023
  • Moving Homey closer

I’ve done multiple combinations of the above (reset before/after pulling fuse etc), but nothing seems to work.

Log entries show that Homey is ready, but there is no connection coming from Z-TRM3.

Another one bought at the same time that I installed now was easily included, instantly after starting the procedure. It’s in the room next to it. There are 7-8 HeatIt devices close to it, and all of them connected instantly.

The only similar problem I’ve had earlier is that the sensor data has been wrong, like 40.000W usage and 450V. But that was solved with re-inclusion after pulling the breaker. At least it did add itself without issues. Now I’m not able to add it at all.

Not sure where to go from here…

I am not entirely sure what you mean, you can use the OFF mode and it will stop regulating the heating.

It is the same, just that Homey requires something to be linked to the On Off switch.

Err means it failed inclusion, how quickly after starting inclusion does it show Err?

How close have you moved the Homey to the device?

How many devices are connected to your Homey?

It seems to run the full cycle, with the spinning animation, and failed with probably a timeout, so it’s there for probably 10-15 seconds?

When it comes to Z-wave, I have 25 devices. All of them are HeatIt. Mostly Z-Dim2 and Z-Trm3.

I tried with Homey approx 1m from the thermostat, and it still didn’t work.

This hasn’t been necessary with any other devices though, I have one Z-TRM3 in the next room (just on the other side of the wall) and it connected immediately.

HeatIt devices has actually been the least problematic devices I’ve ever used with Homey so far these last 8 years.

Thanks for your reply.

My question about relay is:
Is it possible to deactivate the relay in the trm3, so that it no longer switches on or off when there is a heat request?
I only use the trm3 to control homey so there is nothing connected to the relay.

Are you able to remove power to some devices during inclusion so there are less Z-Wave devices active on the Z-Wave network?

That is not possible in this device.
For that type of function, we would recommend you use a Z-Temp2 if you would prefer it to not make sound when the relay turns on.

I’ve added three other devices since trying this one, so it doesn’t seem like the network is the problem. There’s not a lot of traffic, but I do see some devices with 33% loss. So there is something strange going on.

I do have a support ticket going, so I’ll try the suggestions there as well, and update this thread with the outcome.

Long story short:

For some reason a new device reset and putting Homey in the next room, so it was directly BEHIND the thermostat worked immediately.

Dev tools show that it is now making an extra jump through the neighboring room, which makes the signal route longer…

Anyways, it seems to work fine now, sensor data is good etc.

Good to hear it is solved.

The extra jump might resolve itself after a while since within Z-Wave, the Mesh network keeps updating and trying to find new routes automatically.

1 Like

Is it possible to deactivate the relay in the trm3, so that it no longer switches on or off when there is a heat request?

But it’s an interesting thought.
I could also see the use case of an internal version of the therm2.

Another question though - can I use the Z-TRM3 without a load?

I have a room where the floor heating is currently defective (they didn’t protect the wiring so water shorted the coupler) so I was thinking of using it just for showing/monitoring the temperature for now.

Would that work fine?

I could set the temp to 10C so it doesn’t activate the relay.

This is our TV-room, so consoles and TV already heat the room adequately. But it’s floor heating is probably going to be fixed within a couple of years.

I recently bought a Homey Pro 2023 to control 3x Heatit z-trm3 floor heating thermostats, but I’m unable to connect with any of them.

I suspect a bad homey unit, but thought I should check here for advice before starting a RMA.

I have followed most tips regarding Heatit connection procedure: Tested with all 3x thermostats, reset thermostats a numer of times, tried with a variety of ranges to the Homey unit from 0 cm to a few meters. I have yet to try with all devices except 1 powered off, but will try that during the weekend.

Anybody got any other suggestions for me to try?

Regardless what I do Homey will not see a single unit and the Heatits shows “Err” after some time. (After selecting «Con» and watching the spinning circle for a while.)
Unfortunately I have no other z-wave units to test with. No zigbee units either for that matter.