[APP][Pro] Eufy Clean

Hey @andrew_powell
Sorry but i have to say no to that.
Already got you two keys last time and you’re not using this app at all

There are instructions on the internet and the FAQ here to get the keys. But i only do this for app users

Hello all,
I’m currently looking into buying a robot vacuum, and I would like one which I can control locally.
So I would like to ask, does this app work locally (for example, can I block the vacuums internet access in the router). Furthermore I was wondering if anyone who already had a Eufy Robovac if also their own (android) app works locally(without server).
Thanks in advance!

Hey @Timmmeeeeh
Yes this app only works local.

The Eufy Robovacs are Tuya based. The only way to control them are via their official app or via the local tuyaApi.

I think you can close the internet connection to the Robovac. Not sure what it does for the official app though

1 Like

Dear Martijn,

Would you be in the opportunity to help me out finding my localkey for my G30 Edge?
I have tried both using the APK that you provided as well as the adb method, unfortunately I think Eufy has blocked the usage of the older app versions as the G30 shows up as offline and trying to add it from the old version also fails. When I run the adb logcat -e ‘tuya.m.my.group.device.list’ command it won’t show me anything, the cursor will just blink.

I would really like to add my Eufy to Homey to clean my house daily :slight_smile:

1 Like

Hey @Patrick_Pennarts
Will be Thursday due to some days off. i’ll dm you

Great, thanks!

Hi Martijn,

I totally forgot about today, but I don’t know how to DM you on this forum, I cant seem to find the option. Do you still have some time left today?:smiley:

1 Like

I don’t know why but I’m not able to add my C35 again. I connected the vac to my wifi, installed the APK in an Android emulator to get the device id and localkey. After filling that with the local IP I just get presented with Timed out 30000ms. Any ideas?

Edit: 8110a159-56c1-43dc-92ec-c6d8a4fb9439 for the report

Edit2: SOLVED. It was an issue with my Unifi wifi. I disabled BSS Transition and UAPSD and it was working like it should!

1 Like

@timvdhoorn ah nice! :tada:

Hi Martijn,

I am new in t lhe platform en have the Homey 2023 just a couple of days.
I don’t get my Eufy in the app.
I tryed both APK but getting a message that the installation failed.
Can you help me?

Hey @Smoerkie
I’ll send you a DM :slight_smile:

1 Like

Hi Martijn,
I recently got the X8 Hybrid.
Can you help me to get the deviceId and localKey?
I gave the X8 a static IP address.
Wim van Bezouw

Hi @Wim_van_Bezouw
Yes sure. Saw you already sent me a DM :wink:

@martijnpoppen Hi, i have the a Problem. A new Eufy RoboVac C35 but just an Apple Device.
The FQA dit not help me :face_with_open_eyes_and_hand_over_mouth:
How you can help me ? How does it work, that you can get my keys ?
Best regard Peter.

Hi @martijnpoppen I have just received my X8, can you please help me getting the DeviceId and LocalKey?

Thx! Casper Roos nl user

Ps think i sent you another request but can’t find it anywhere.

I have the Homey 2019 pro with your Eufy home app installed but needcthe info to add it to the app. Not sure what you need from me. Thanks in advance

@Peter_van_Meer sent you a DM

@Casper_Roos i replied to your DM :slight_smile:

I have the same time-out for my G10 Hybrid.
Unfortunately I don’t understand what you changed in your Wifi settings to get ut solved.
Could you help me out?

Thanks in advance!

Hi @martijnpoppen,

Sorry maar ik ben nieuw hier en ik kan geen optie vinden om een DM naar je te sturen dus vandaar via deze weg. Ik heb een X8 Hybrid en met de laatste versie van jouw app krijg ik de melding dat de app te oud is. Ik heb trouwens een Homey Pro (2023).

Hoor graag van je, thx!

Hey @Wiedse_Hiemstra

Sorry i’ll reply in English as this is a international topic :wink:

If I understand correctly you’re looking for a way to retrieve the keys to use your Robovac in Homey is that correct?