[APP][Pro] Easee charger

Im having problems
image
and
image
doesnt work, but the information is correct


I dont get any errors in the flows and not any 404-errors like there where in december, the flowcard just seems to take a little bit longer time than usual

Any suggestions?

/Rikard

I have encountered an issue when trying to add my second Easee charger (cabin) (also had some issues initially with the home charger but that appears to have been just intermittent issues).
I raised an issue in Github but looks to be little activity there, so not sure if this forum might be the preferred place for support cases (?).

Have several times removed + add the device + restarted the app. No difference, it still claims “failed to retrieve the site if and circuit id” and shows up as “charger.name” in Homey (with red exclamation mark)

Some observations:

  • Homey: Under device (charger.name) → Advanced Settings, both the Site id and Circuit id and other settings shows up correctly.
  • Homey: Under invocation statistics (in Easee Home app → Configure), both chargers appear under “invocations by endpoint(…)”.
  • Both chargers appear when testing at Products

So it looks like there is no issue with connectivity and API calls, which makes me think there is a bug in the Easee Home app in Homey.

Details and screenshots in Github: Unable to add my chargers · Issue #43 · ricott/homey-no.easee · GitHub

Anyone experiencing the same?

Beside the challenges with my cabin charger, I have to say that this is a great app (works very well for my home charger), really appreciate it @Richard_B

I have spent some time testing on my chargers and the commands API is back at taking a long time, 25-30 seconds when I test it from my laptop. I have pinged Easee on Slack.

Further, it seems they have changed the logic around the commands API. Before if we triggered a start command on a charger that was paused they would return that the command wasn’t accepted and then the Homey app sent a resume command to see if that worked - which it usually did. Now the response is that the start command was accepted - but it doesn’t start charging … resulting in the Homey app never sending the resume command. Will ping them about this one as well.

Travelling and super busy at work, little time for pro bono work these days…

Yes, there seems to be a synchronization problem in the code, will try and fix it and issue a new release.

3 Likes

After some more investigation it seems that all information from the easee-charger are updated in the homey, its just the commands to the easee chager that doesnt get true

thanks for good work

/Rikard

tested the new version now, it dosnt help

/Rikard

Ive also oppend a ticket att easee support complaining about what their doin.
It makes the charger totally worthless if I cant trust it.

/Rikard

1 Like

Hello, @Richard_B

I am using only the equalizer for power meter measure and voltage measurement.
So far, it works great.

But is it possible to add forced update intervals to homey app? Settings update time?
Or update threshold for power import figure watt?

The small problem I have, if the live consumption is steady, it can take up to 15 minutes before power import update. I would like to have it on like 10-30 seconds.
Is there an solution for this?

Thanks!

Thanks for the fix. Much appreciated. Totally understand the “pro bono” comment (Easee should buy your app tbh), I was just confused where to report the issue :+1:

1 Like

Further testing today shows that I never get anything else than 404 for my chargers. The command endpoint never appears. Tested after 5 minutes, it is still not there.

Both my chargers are added to Tibber, and now I notice there is no start/resume charging button in the Easee mobile app or web. Can someone with Tibber (I guess any partner) check if you see the start/resume charging button or not in the Easee mobile app/web.

For the chargers we have this endpoint, I call it automatically to refresh the lifetime value. I don’t see anything similar for the Equalizer though. Which makes me think it is currently not possible. The app fetches it every time it fetches the other values, it is the same API. But I guess Easee internally doesn’t refresh it as frequently as the other values.

I have tibber and I don’t have the start button on Easee app as well.

1 Like

I have the start button, but i have disabled smart charging for tibber.
But i have never tried it, al my charging is controlled via homey, and if thats broke i start manully from the tibber app, or as now, i set a scheme in easee app, it worked this night

/Rikard

1 Like

Thank you for quick reply. I understand, im ok with that.
Maybe there will come something in the future.

Got a response this morning that they will look at it (404 on commands endpoint), lets see what they find.

1 Like

… and we are back :muscle:
Easee fixed the commands API endpoint. Works fine when I test it on my Homey.
Will ship a minor fix still, to give a proper error when we have exhausted the max number of retries on the commands API.

2 Likes

it seems to work for me as well

More testing tonight when my flows shall controll the charging

/Rikard

I can confim it works great for me

1 Like