[APP][Pro] Easee charger - Small. Smart. Full of power

Hi @Richard_B , today I realized that my car didn’t start charging (using automated authorization when home member arrives and plug the charger) and when looking on the charger state, it shows in last API error :

2021-09-21 22:00:01
Error: Access token expired, HTTP status code ‘401’
at /lib/easee.js:480:39
at processTicksAndRejections (internal/process/task_queues.js:97:5

Diag. code b8370294-0fdb-464f-9754-538c35281d49

…so OKay, I thought I will “repair” it yet (like from time to time I have to do eg. with Netatmo), however seems that you didn’t enabled this option (, so I initiated process of adding new Easee device, which didn’t find any new (as expected) and then restarted the app - and it’s working again…

I wonder can you please implement that repair stuff ? I think this is described here - Pairing - Homey Apps SDK but I believe it’s nothing new for you. Maybe it’s due to the “Reorder” functionality ?

Do anyone have a good flow/solution to my problem?
My Easee charger is controlled by my power supplier (Tibber) who controls when to start charging.
I have an Hyundai Kona who goes to a deep sleep after a while without charging.

In most cases I put the charge cable in at around 18.00, but Tibber wont start smart charging before 23.00, by that time the Kona has ended up in a deep sleep, and Tibber/Easee cannot start charging.

Is there a good status or something that I can monitor to understand when Easee “starting” charging, but the car is not receiving? So I can trigger an charge event from the Hyundai APP in Homey?

I tried with a flow yesterday, that I thought would do this:

But when checking in Homey my charger was not set to Error, only “Car connected”(?). But I think that the status was the same from I inserted the charge cable (18.00)… I thought the Easee would end up in a error (or other) state when Tibber starts charging and the car don’t charge…

Hopefully someone has some input :slight_smile: Thanks!

And yes, I can create a flow that runs every hour between 22:00 and 02:00 for example checking if status is “Car connected” and then start charging… But I don’t have any clue if Tibber actually has told Easee to charge

@Richard_B Thanks for creating this app! I am having one issue that isn’t really serious, but it is a bit odd: The phase currents shown are different to the currents shown in Easee’s phone app. Right now I am charging, and I have these currents shown in the Easee phone app:

L1: 26,4 A
L2: 15,3 A
L3: 14,7 A

In the Homey app I get:
P1: 15,3 A
P2: 14,7 A
P3: 0,03 A

What could be the reason for this discrepancy?

Hi Richard, many thanks for your very great App.
There is one thing that I sorely miss: the ability to reconnect my charger to the cloud.
In the last few weeks easee had problems with the cloud several times. Unfortunately, the connection between your app and the cloud server is always gone afterwards. In order to perform a “reconnect”, however, I have to delete my wallbox from the configuration in order to reconnect it with easee. This of course means that there are no entries in the flow afterwards, since the device has been deleted in the meantime.
It would be very helpful if you could implement a “reconnect” function within your app without first deleting the device (wallbox) and then reconnecting it.

Already reported that on Sep 22, no reaction since then unfortunately… :frowning:

yes you are right, i found it.
Maybe as a reminder …


Thanks for a brilliant app.

I have a request:

Some times when the charger enters an error state for some reason, and the easy solution is often to reboot the charger.
The problem is that the car normally charges at night, so I don’t notice the error until morning, and the car has not charged over night.

I see that the api has a reboot command, so adding that command to an action card would let me reboot the charger when error occures and my problem would be solved.

Any chance you could add a “Reboot charger” action card?

Is it the charger in error state (so you see it also in official app) or it’s Homey app, where it reports error. For 2md case I’m using restart app ootion if device is not reporting for 2 hours.

If it’s official app which reports issue, then I would suggest to contact Easee directly.

The charger in error state. I have experienced the official easee app saying the car tried to draw more current than allowed and hence the charger goes into an error state. The only way to get rid of the error state is to reboot the charger, so it would be nice to be able to do that through homey when it happens at night (WHEN status changed AND status = Error THEN Reboot charger).

Unfortunately only @Richard_B might have a solution for you but as you can see, author got silent for some time already.
Maybe a workaround using IoBroker and this adapter might be temporary solution for you.
GitHub - Newan/ioBroker.easee: easee is a wallbox with an REST-API. This adapter for ioBroker can used to connect the wallbox with your home environment - then via MQTT topic easee/0/yourEaseeSN/control/reboot - I was just testing it and it’s possible to send restart signal via this. But you need to be familiar with MQTT and IoBroker etc. - please search around the forum.

Note : illogically for me, it seems you need to send FALSE to easee/0/yourEaseeSN/control/reboot for reboot…

Ok, thanks … I’ll look into it. I was not aware that the author of the app had gone silent. I just figured it would be an easy addon since the command is in the easee api. Cheers.

I’ll try and iron out some time to do an overhaul of the Easee app. There are new API endpoints for login for instance. The repair function can for sure be changed to re-login rather than re-arrange capabilities. To be continued …

1 Like

There is a test version with;

  • support for the new login API from Easee
  • new repair function named Reconnect
  • new Reboot action
1 Like

The previous version is live, so I guess I would have heard if there are any issues :slight_smile:

There is a new test version that aims to solve the problem with the Equalizer and Norweigan IT grids.
I recommend folks with an Equalizer to try out the test version before it goes live.

@Richard_B well not sure, I’m trying since beginning but have some weird issues , like getting that device is not responding last 2 hours etc - but as I have auto app restart in this case, I don’t see any problems later (I have this as workaround prior you implement Repair function). Will report if I will find out more. But if you will observe anything : b10b6e89-9ae1-425e-9b0b-7347f6f8a6f4
(not Euqualizer user though)

Btw, authorising charging (NFC/RFID or in the app) - it is the same as Enable charging? Or Start charging will override anyway ? It’s working for me, I just wonder to be 100% sure as I’m authorising it physically.
Thank you.

Do we have any users with IT grid type here that could verify recent changes to the support for this?

I have two chargers on my site (same circuit), but the devices in Homey no longer receives status updates. This is annoying, since I have monitoring for power usage and calculations for cost, and this was of course dependant on getting updates to power usage.

I have tried entering settings and pressing “reconnect”, but it doesn’t seem to help. Using a flow to set dynamic current does work as it should though, so the Homey app does indeed communicate with the Easee cloud.

Is it a known problem that status updates does not work?

Hi Richard,

I’ve been using your app for a long time, very good, I was looking for something like that. Since I often no longer have a connection to the wallbox after maintenance of easee (the wallbox itself incls. easee app are running), I had asked for a “reconnect” a long time ago so that I didn’t have to delete the wallbox every time to get back to me to register. Have now installed your new version 1.2.9 because the box is “gone” again, unfortunately the “reconnect” doesn’t seem to work.
Do I have to pay attention to something specific, or do I have to register again in the current app version?
Thanks you for your help.

@Richard_B Do you have any suggestions as to what we can do to get the devices updating status again? As I said, setting current from a flow does work, so it can connect to the Easee cloud, but my chargers hasn’t had any status updates for days. “Reconnect” does nothing.