[APP][Pro] Daikin AI

Thanks Peter!
Installing it fixed my flows instantly!

1 Like

INFO
The Daikin Residential Controller app can now also be used to control airco’s that till now used the Daikin Online Controller app. It involves creating a Daikin account as well as an airco firmware upgrade, the latter is automatically installed during pairing of the airco with the Residential Controller app.

Nothing seems to be broken after the firmware upgrade.

Hmmm. I must be doin something wrong.
I installed the app, chose add device. Entered the IP adress plus a name, ticked off all the three selections and clicked Add.
The add device disappears without warnings or so, but no device is being added.

Type of adapter?

FTXM35R with the WiFi adapter. I know it was NOT supported in the past, I interpreted your “INFO” on 2nd Feb that it was now supported, or is that a wrong interpretation

That was a wrong interpretation… read this [APP][DEVELOPMENT] : Daikin Residential Controller / ONECTA

Ah ok. Thanks for sharing that

It was already shared before… read the thread :wink:

Hi.

I used to use ‘Daikin Online Controller’ but have now switched to ‘Daikin Residential Controller’, both seems to work perfect with my Daikin. The Residential Controller app is much more up to date visually.

I use Daikin AI in Homey, and it works good. Missing power co consumption but as I understand that’s Daikin fault? Have you or others asked Daikin why this isn’t open when Daikins own app shows this?

You misunderstood, the reverse engineered Daikin API this app uses does not support a power consumption feature that is compatible with Homey’s implementation. That said my app will never support the power consumption feature some models do support in the official app. Btw my own Emura 2 does not support power consumption in the official Daikin app.

Here is mine, the strange part is that its not listed on the Homey Residential app either, but I just tried the Daikin Residential app when i spotted it on the App store and everything seems to be great :





Nice, enjoy :wink:

One question, do you have any idea on what to do when the Wi-Fi module don’t seem to talk with Daikin Ai? Everything have worked great until to day. Had a short power loss last night, and after that it seems that commands sent from Homey to heating pump don’t get there, and the same, the temperature from the pump don’t get in to homey…

I have tried restart the app, and turned off and on Daikin but no change.

The Daikin app works like it should it seems like

Do you make use of a fixed IP-address for your airco or not? If not check the IP-address the airco is now using and reconfigure Daikin AI. See also the “user manual” at the top of this thread…

1 Like

Ahh, didn’t think of that, that is probably the problem of course

Thanks!

It was. Great!

1 Like

Hi everyone, I had a question. Is there an option to use the Daikin App without Homey Pro? Will this be available for Homey Beta?

I have purchased the Homey Bridge, but I cannot connect it yet. I think it would be nice if I could also process the daikin’s in the flows of homey.

Thanks in advance for your response!

Greetz, Bram

2x no, the app uses local wifi which is not supported by Homey Bridge (ice puck).

Check out https://community.homey.app/t/app-development-daikin-residential-controller-onecta/

App is written for Homey Pro but its prepared for Homey(bridge of cloud).

A soon the app is launched for the pro and bugs are solved the next step is to launch the app for Homey (bridge of cloud).

Hello,

I have a problem using this app to control my units.

I have two : BRP069B4x units.

I added both of them on homey pro.
They respond well as I can see the inside, outside and even the desired temp.
Also, when I turn the units ON with the remote or the ONECTA app, i can see the operating mode on homey.

But if I want to turn the unit ON or OFF via homey it doesn’t work.
I can set the desired temp, the icon will become blue for 2-3 seconds, then it will come back to the black backscreen as if I didn’t do anything…

I already tried to reinstall the app.

I used the non homekit selection when I add the devices (as I don’t have the HomeKit integration in the ONECTA app).

Any idea how I can get this working?

Best regards,

Nicolas