[APP][Pro] Daikin AI

I get an error message when i open daikin AI devices:
“Complete the driver update”

This makes the devices not work - does anyone know what this error is?

Upgrading from an older version I guess?

Hi, I have the Daikin FVXM35A floor model, but it seems like it is not supported in the app. Any plans for this in the future?

When i go to http://my.ip.add.ress/aircon/get_control_info, it gives me:

Page Not Found

Which official Daikin app do you use to control the airco, ‘Daikin Online Controller’ or ‘Daikin Residential Controller’?

I am using the Daikin Residential Controller. I read the sticky post, and can see it is not supported as of now. Thanks!

Check this out [APP][DEVELOPMENT] : Daikin Residential Controller (BRP069C4x)

Hi Peter,

I found recently that a flow responding to changes to the target temperature on one of my Daikins was broken in the sense that the triggering event was not recognized. Possibly because I removed and re-added the device. So I tried to add the same triggering event again. But it seems as if this event is no longer available.

The old broken event shows still the ID target_temperature_changed. So it did exist before.
But in the current list if events I cannot find it anymore …
Added screenshots of the old event and the current event selection dialog.

Thx for reporting, I will have a look.

@Joseph fixed my bug, sorry for this. Updated app available via the App Store in the test channel, version number is v5.1.11.

Thanks Peter!
Installing it fixed my flows instantly!

1 Like

The Daikin Residential Controller app can now also be used to control airco’s that till now used the Daikin Online Controller app. It involves creating a Daikin account as well as an airco firmware upgrade, the latter is automatically installed during pairing of the airco with the Residential Controller app.

Nothing seems to be broken after the firmware upgrade.

Hmmm. I must be doin something wrong.
I installed the app, chose add device. Entered the IP adress plus a name, ticked off all the three selections and clicked Add.
The add device disappears without warnings or so, but no device is being added.

Type of adapter?

FTXM35R with the WiFi adapter. I know it was NOT supported in the past, I interpreted your “INFO” on 2nd Feb that it was now supported, or is that a wrong interpretation

That was a wrong interpretation… read this [APP][DEVELOPMENT] : Daikin Residential Controller / ONECTA

Ah ok. Thanks for sharing that

It was already shared before… read the thread :wink:


I used to use ‘Daikin Online Controller’ but have now switched to ‘Daikin Residential Controller’, both seems to work perfect with my Daikin. The Residential Controller app is much more up to date visually.

I use Daikin AI in Homey, and it works good. Missing power co consumption but as I understand that’s Daikin fault? Have you or others asked Daikin why this isn’t open when Daikins own app shows this?

You misunderstood, the reverse engineered Daikin API this app uses does not support a power consumption feature that is compatible with Homey’s implementation. That said my app will never support the power consumption feature some models do support in the official app. Btw my own Emura 2 does not support power consumption in the official Daikin app.

Here is mine, the strange part is that its not listed on the Homey Residential app either, but I just tried the Daikin Residential app when i spotted it on the App store and everything seems to be great :