[APP][Pro&Cloud] Shelly

This is unrelated to the latest update. Follow the networking troubleshoot guide from the first post.

No, this feature is giving more trouble than it does good. If you just fix the CoAP traffic in your network updates are instant and you would not have to rely on polling. See the networking troubleshooting guide from the first post.

Hi all,

I have the following set up:
Shelly i3 to switch on/off a regular shelly 1 (having a light connected to it). This shelly 1 in turn activates 3 Hue lamps through a flow.

The Shelly1 switches on almost instantly after flicking the i3/lamp switch, so communication between the i3 and shelly1 is running smooth. However, it takes a really long time (like 20-30 seconds) before Homey’s dashboard also shows that the Shelly1 is actually on (as in, the symbol for this shelly lights up). As a result, the flow activating the 3 Hue lamps is only started 20 seconds after turning on (or off) the other lamp that runs on the Shelly1.

Any ideas on how to resolve this? Thank you!

Check step 2 from the troubleshooting guide from the first post.

1 Like

Updating the firmware through the Shelly app fixed my timeout error. Thank you.

Since 2 days i cannot control the shelly devices anymore. I uninstalled the app and installed it. Now there are some devices i can add bur some i cannot. After adding nothing happens.
If i look in the shelly app everything is working.
What can i do?


Follow the trouble shooting guide from the first post on the topic.

Hi I did this all. The shelly devices have a static ip. I deleted all devices and unistalled teh shelly app in homey. After a reboot i installed it again. When i add the shelly device i can see all the devices. When i select one and click on a device it only shows a screen new devices found and than nothing. i dont know what to do anymore. I can access the devices in the shelly cloud app

Hi, please have anyone the Shelly PRO 3 unit? It is a 3 channel relay switch module (dry contacts).
I installed it today. In Shelly app works everything fine. But if I add it to Homey i see only one channel. I have also the Shelly 4PM unit this unit shows in Homey 4 Independent diveces, but this PRO 3 only one. Any help?

Have you tried removing this channel 1 and just re-pair it again. Might just have been a glitch during pairing.

Ok that’s working :grin: after i deleted the one and restarted the Shelly app and tried again it added 2 channels after repeating the procedure once again now i have all 3 channels. Thank you

hi, I have problems adding the Shelly thermometer. I had it added earlier, but changed to a different wifi with same wifi name and password. It is working in Shelly Cloud. It is pairing to Homey that is the problem. It even sees the devices, but nothing happens after I select the device. What should I do? Reinstall the app or empty its cache?

Make sure the device is kept awake during pairing by pushing it’s wake up button during the pairing process.

1 Like

yes, was doing that. But it is solve dnow. After turning off 5GHz in the mesh wifi network used for my smart devices, it worked. I have now added all my shelly devices to Homey.

Hello, since the last update it seems that some Shelly devices are not supported anymore. I am not able to add to door/window sensor to homey (firmware updated). Is there someone experiencing the same issue and could I ask you if there is some solution available?

As mentioned on your down rate in the app store. All Shelly devices are supported. Follow the pairing instructions to the letter. For battery operated devices you need to keep the device awake during pairing by pressing the wake up button.

And please update your app store rating once you have them paired and come to the conclusion this was a human error.


Hi Phuturist, thank you for your answer. I have followed the pairing instruction word by word, but I couldnt get the sensor added to Homey. However I have tried to pair another door sensor and it went well, so it seems, that there is something wrong with my device. The only issue I am now having is the warning in Homey app that the device might not be supported in the future (shelly sensor is fully updated, with fix IP address).

There was communication in the changelog and here on the forum about this some time ago. The app has gone through a major change where specific device type drivers have been replaced by a generic driver which can be used to pair any Shelly device. Although devices paired with the deprecated specific device drivers will continu to work you are encourged to re-pair them with the new generic driver to ensure you dont miss out on improvements and features.

Hello, somebody has an idea what is happening to the Shellys 1PM ? Yesterday first the one at the TV sweitched itself on when he wanted and now my Shelly 1PM doesn´t respond anymorte to the app anfd to google home. Can only turn it on and off via Shelly app.

Any ideas?