[APP][Pro&Cloud] Shelly

The first generation use a simpeler authentication compared to the Plus/Pro devices which is a PITA from an integration perspective. A lot has changed over the weeks and appareantly this is now partly broken. I’m sure you wont have issues without authentication. But could you enable it again and send me a diagnostic report the moment you notice the device is not responding anymore.

Ok, dont know what the issue is then. Could you send me a diagnostic report, perhaps there are clues in there.

Hi Jelger,

You’re right, without authentication, everything works.

How can I generate a diagnostic report? I’ll generate two reports, one after enabling and one after the functionality doesn’t work anymore.

Greetings Joost

88e23c5b-5eb1-4492-8656-7b0eb4f0e1c9

From the Settings > Apps > Shelly.

The log is full of other Shelly devices that cant be reached suggesting networking issues. These issues are out of my hand. I will return the diagnostic report so you can see which devices are not responding. Best I can offer you is following the troubleshoot guide from the first post in this topic or suggest re-pairing all these devices in the hope that fixes the where Homey cant reach your Shelly devices.

Uh ok. I have no issues with other Shelly devices. They all work as I expect. Didn’t you find any clues voor de Shelly I4? How do you send the report?

In any way, thanks for your efforts!

I believe I understand the errors from last night. That’s when I updated my access points :wink:

Ok, please reboot the Homey, wait 5 minutes, switch an input connected to the Shelly Plus i4 and send me another diagnostic report. That should not be cluttered by these networking errors.

Ok done.

856bc717-af29-48de-bcea-48c5efcac918

Hi Jelger,

This is the code: bea02258-34a1-4cab-a178-ff3ce939c5de

Greetings Joost

Mvg Joost

It’s a bug which I’ll fix in the next release.

1 Like

When you disable the device authentication does it now also directly update the device status in Homey when you switch the device from the webinterface?

And do you have static IP adresses configured for your Shelly devices?

Hi Jelger,

Yes it did, and yes I do have an fixed IP address for my Shelly devices :blush:

Greetings Joost

Found the issue, will be fixed in the next release.

1 Like

Tnx Jelger!

Mvg Joost

Thanks Jelger!

Hi!

Found a flaw in the RGBW2 unit when setting the hue using a tag. I calculate a variable everytime the electricity price change and send that as a tag to set the colour/hue between 0 and 100 in the scale.
Everytime the colour/hue ends up bright red wich corresponds to 0/360. Manually setting the variable and sending to the unit gives the same result. Manually changing hue works fine.

Best regards.

I’m suspecting the flaw is in the way you are using it and not the app or the RGBW2 unit. Hue is supposed to be a value between 0 and 1. So divide your calculation by 100 and see if that fixes it.

1 Like

My god……. I was so fooled by the 0-360 degrees scale in the GUI in Homey!
0-1 did the trick! Awesome! Thanks for the lightning quick reply.

1 Like