[APP][Pro&Cloud] Shelly

Yes, I’ll look into it.

Great thanks a lot! The Shelly 3EM is used a lot to manage the charge of electric vehicles in connection with solar panels, and in this context the total power value (Export, negative value) of the house is very important. Thanks a lot!

Hi, I’m having problems adding a Shelly Door/Window 2 to Homey.
It has a static IP in my network and I can access its web page.
I can add it in the Shelly Android app but it is not found by Homey and if I try manual add in Homey, I get unknown error :frowning:
This particular DW2 sensor has previously been installed on this Homey, but Homey did not report its values so I uninstalled it, hoping reinstall would fix it. That has worked with other device types…
I have over 100 other Shelly devices installed, this is the only DW2.
The Homey is a 2019 Pro running 7.4.2 and Shelly 3.9.12

Restart Homey, wait 2 minutes, wake up the DW2 using the button, use the Web interface of the DW2 to make sure it’s discoverable (under the Settings menu), reboot the DW2 from the Settings menu and pair it with Homey 30 seconds after rebooting it.

Thanks, done that and tried several previous versions of the DW2 firmware, still no luck :frowning:

Are you sure it’s not already paired? With over 100 Shelly devices I can imagine you can loose track. Paired devices wont show in the pairing wizard.

As sure as I can be, tried giving it a new IP, still no luck :frowning:

Devices are recognized over mDNS. There are a few conditions that have to be met, you could try and rule them out 1 by 1:

  • Homey and the device are on the same LAN
  • The device is awake when pairing (battery operated devices sleep most of the time and need to be woken up)
  • The device is actually discoverable over mDNS (this can be enabled/disbaled through the setting of the device, for battery operated devices it’s sometimes only discoverable shortly after rebooting the device. You can check if it’s discoverable using a bonjour / mDNS tool on a laptop or smartphone)
  • The mDNS message has a specific format so it’s recognized by my app (in this case it should start with shellydw2-)
  • The device is not already paired as already paired devices are not shown in the pairing wizard

There is not much more I can do about this.