[APP][Pro&Cloud] Shelly

X Error: Er is een onbekende fout opgetreden [unknown_error]

Nice, very useful. Could you test step three from the networking troubleshoot guide from the first post in this topic.

Do u have a flow example? I am trying, but don’t know how.
Schermafbeelding 2022-04-05 om 21.20.40

Thanks! This flow is successful without password protection. Shelly is reachable?

I made a report:

f59233c5-67d0-4737-bd78-f3f6c5a01e1e

Shelly config:
{“wifi_sta”:{“connected”:true,“ssid”:“Netwerk Ruben & Pieter”,“ip”:“192.168.2.214”,“rssi”:-44},“cloud”:{“enabled”:true,“connected”:true},“mqtt”:{“connected”:false},“time”:“23:11”,“unixtime”:1649193070,“serial”:6,“has_update”:false,“mac”:“98CDAC253E99”,“cfg_changed_cnt”:5,“actions_stats”:{“skipped”:0},“inputs”:[{“input”:0,“event”:"",“event_cnt”:0},{“input”:0,“event”:"",“event_cnt”:0},{“input”:0,“event”:"",“event_cnt”:0}],“temperature_status”:“Normal”,“update”:{“status”:“idle”,“has_update”:false,“new_version”:“20220209-094909/v1.11.8-g8c7bb8d”,“old_version”:“20220209-094909/v1.11.8-g8c7bb8d”},“ram_total”:51584,“ram_free”:38904,“fs_size”:233681,“fs_free”:155620,“uptime”:14304}

Could you post the output from /shelly and /settings as well. And have you already tried rebooting everything, including the i3? And you could look into the mDNS broadcast by using an app called Service Browser (which is for Android but I assume something similar exists die iOS) and see what these new devices are broadcasting over mDNS compared to the already paired devices.

Hi!
I’m trying to use the new Shelly action card together with Shelly 1 but can’t get anything to happen. I have created a flow with the action card and selected the Shelly 1 to trigger on short push to set a variable in Homey Bridge but nothing happens. The same with Long Push. If I test the flow with the test button, the variable sets but not when I press the Shelly 1. Have verified the Shelly 1 in the Shelly App and made a scene that works with both short and long push so the problem seems to be in Homey, not in Shelly.
I’m using the latest version of the Shelly app 3.9.5 but an older version of the Homey FW 1.9.4 as the latest fw keeps losing connection with my wifi (mesh).

The flow: [Shared Flow | Homey]

Any idea?

/Peter
(I’m sorry if I keep posting this issue in the wrong place)

I assume you mean the Shelly firmware. I can not garantee my app to be working with outdated Shelly firmware. If you have updated to the latest firmware and still experience this issue let me know (including if it occurs on Homey Pro or Homey Cloud).

I already rebooted i3 and Homey, without succes.

/shelly:
{“type”:“SHIX3-1”,“mac”:“98CDAC253E99”,“auth”:false,“fw”:“20220209-094909/v1.11.8-g8c7bb8d”,“discoverable”:false,“longid”:1,“num_inputs”:3, “num_outputs”:0}

/settings:
{“device”:{“type”:“SHIX3-1”,“mac”:“98CDAC253E99”,“hostname”:“shellyix3-98CDAC253E99”,“num_inputs”:3, “num_outputs”:0},“wifi_ap”:{“enabled”:false,“ssid”:“shellyix3-98CDAC253E99”,“key”:""},“wifi_sta”:{“enabled”:true,“ssid”:“Netwerk Ruben & Pieter”,“ipv4_method”:“static”,“ip”:“192.168.2.214”,“gw”:“192.168.2.254”,“mask”:“255.255.255.0”,“dns”:null},“wifi_sta1”:{“enabled”:false,“ssid”:null,“ipv4_method”:“dhcp”,“ip”:null,“gw”:null,“mask”:null,“dns”:null},“ap_roaming”:{“enabled”:false,“threshold”:-70},“mqtt”: {“enable”:false,“server”:“192.168.33.3:1883”,“user”:"",“id”:“shellyix3-98CDAC253E99”,“reconnect_timeout_max”:60.000000,“reconnect_timeout_min”:2.000000,“clean_session”:true,“keep_alive”:60,“max_qos”:0,“retain”:false,“update_period”:30},“coiot”: {“enabled”:true,“update_period”:15,“peer”:""},“sntp”:{“server”:“time.google.com”,“enabled”:true},“login”:{“enabled”:false,“unprotected”:false,“username”:“admin”},“pin_code”:"",“name”:null,“fw”:“20220209-094909/v1.11.8-g8c7bb8d”,“factory_reset_from_switch”:true,“discoverable”:false,“build_info”:{“build_id”:“20220209-094909/v1.11.8-g8c7bb8d”,“build_timestamp”:“2022-02-09T09:49:09Z”,“build_version”:“1.0”},“cloud”:{“enabled”:true,“connected”:true},“timezone”:“Europe/Amsterdam”,“lat”:52.153500,“lng”:5.377460,“tzautodetect”:true,“tz_utc_offset”:7200,“tz_dst”:false,“tz_dst_auto”:true,“time”:“16:03”,“unixtime”:1649513023,“led_status_disable”:false,“debug_enable”:false,“allow_cross_origin”:false,“actions”:{“active”:false,“names”:[“btn_on_url”,“btn_off_url”,“shortpush_url”,“longpush_url”,“double_shortpush_url”,“triple_shortpush_url”,“shortpush_longpush_url”,“longpush_shortpush_url”,“btn_on_url”,“btn_off_url”,“shortpush_url”,“longpush_url”,“double_shortpush_url”,“triple_shortpush_url”,“shortpush_longpush_url”,“longpush_shortpush_url”,“btn_on_url”,“btn_off_url”,“shortpush_url”,“longpush_url”,“double_shortpush_url”,“triple_shortpush_url”,“shortpush_longpush_url”,“longpush_shortpush_url”]},“hwinfo”:{“hw_revision”:“prod-2020-04-21”, “batch_id”:1},“longpush_duration_ms”:{“min”:800, “max”:3000},“multipush_time_between_pushes_ms”:{“max”:500},“inputs”:[{“name”:null,“btn_type”:“momentary”,“btn_reverse”:0},{“name”:null,“btn_type”:“momentary”,“btn_reverse”:0},{“name”:null,“btn_type”:“momentary”,“btn_reverse”:0}],“eco_mode_enabled”:true}

mDNS:

Nothing strange there, I can not help you with this.

Hello,
all shelly devices disconnect from my homey but not from the network. I see all red triangle on all shelly devices on the app and after few minutes all of them come back active.
It happen quite often (more or less at least one time a day). Last time happened half hour ago.
Firmware of shelly devices updated on last week on all devices.
I created a crash report c1851da0-751e-4c56-bd5d-c5c3a9702746 if it can help.
Any hint is appreciated.
Thank you
Regards

Probably nothing i can do about it. See the networking troubleshoot guide from the first post in this topic.

I use a shelly 2 for about a year or so and I use it for the mechanical ventilation.
For 5 days or so it worked fine. When I now turn on the ventilation nothing happens, it stays running on the same speed. When turning it on with the IP adres in a browser then it works fine.
I am on firmware 7.2 for Homey, updated an hour ago the Shelly app (3.9.6) and updated also the Shelly firmware. Restarted the app, but the ventilation stays off.
Any idea?
Also a Shelly 1 isn’t working anymore.
Restarting Homey also doesn’t work.

This is not related to any of the latest updates. Else a lot more people would complain about it. Follow the troubleshooting guide from the first post. There is something wrong in your setup / configuration.

1 Like

I wil have a look at the first posts if I can try something.
But the strange thing is if I turn of COAP in the app and I turn on the Shelly 2 with the original Shelly app the Homey app changes and the up or down arrows changes with the Shelly app.
But when I switch in the Homey app manually nothing happens, only the icon lights up, the arrow up or down.

I did try a few things but didn’t work.
I removed the Shelly’s and repaired 15 flows and now they both work again.
Keep up your good work. Thank you. :+1:t3:

Hi,
Is it possible to reset power measurement on a Shelly 3EM?

Yes, by factory resetting the device but you’ll loose all other settings as well.

That didn’t work. I was in contact with Shelly and the only way to reset measurement was to send them the device ID and then they could reset measurement.

I miss the state on Shelby plus 2pm shutter. It looks state is not showing or working to create a flow.

I’m trying to create a flow with a state up or down.

Have you configured it as roller shutter?