[APP] Fakro

Yes, I did that before I added it to homey. It’s homey that hasn’t released it now

hi @K_S Your description sounds like you have some older generation Fakro devices (like me) which haven’t support in the app for pausing the movement on any moment (as opposed to either fully closed or fully opened).
I am still in contact with the developer that builds the Fakro app. I am actually sending out my own window chain motors to him so he can try to re-engineer and test these older generation devices for a proper implementation in the next update(s).

As far as your issue with the removal of your device; I don’t know how to solve that. Hopefully some other member here can help you with it!

Well, I did find a way to stop them once in motion using Homey. These are the states that I was presented with as options:

So I created a flow that sent a Set State to “Idle” command, but the Fakro App responds so slowly its unusable / unworkable (the window is either almost fully open/closed by the time it responds))

I managed to release it from Homey’s Z-Wave network it by using a Fibaro Homecenter 2 and forced exclusion.

Does anyone have managed to include Fakro ARF windowblinds to their Homey. I need help. The app says that I should put the unit in “Learning mode”. I have tried this by at first make a factory reset of the blind (5x P button), then put it in learning mode (OFF ON, OFF ON, OFF ON of the mains) with the result of P led indicator flashing. So far so good but Homey still won’t recognise it. Nothing happens in the app. It still says “put z-wave unit in learning mode”.
Please help or guide me to someone who might be able to help out.

Thanks

Hello @JonE,

Are you still in touch with your Fakro app developer friend?

(I’m still not getting any response to the email address on the contact link)

Since ‘upgrading’ to Homey Pro 2023 in an attempt to improve z-wave stability, I have lots of error messages from z-wave devices complaining they cannot work because there is too much traffic.

The culprits seem to be the Fakro devices or app. I have in my timeline many messages for the Fakro devices “…is sending a lot of z-wave messages. Please check the device configuration to prevent network congestion

I’ve tried setting the polling interval from 5000 ms to 120000 ms.

Irrespective of what I set, the app sends info to Homey almost continuously from one of the 5 Fakro devices.

The log shows in for example in just a 2 minutes sample, 4 Fakro devices are communicating 141 times, basically accounting for more than half of all the entries, despite there being 75 other z-wave devices, with these kind of entries:

[2023-08-14T15:34:27.600Z] Node[128]: [COMMAND_CLASS_SWITCH_MULTILEVEL] {"Value (Raw)":{"type":"Buffer","data":[87]},"Value":87}
[2023-08-14T15:34:27.633Z] Node[128]: [COMMAND_CLASS_SWITCH_MULTILEVEL] {"Value (Raw)":{"type":"Buffer","data":[87]},"Value":87}
[2023-08-14T15:34:27.754Z] Node[130]: [COMMAND_CLASS_SWITCH_BINARY] {"Value (Raw)":{"type":"Buffer","data":[255]},"Value":"on/enable"}
[2023-08-14T15:34:27.879Z] Node[130]: [COMMAND_CLASS_SWITCH_BINARY] {"Value (Raw)":{"type":"Buffer","data":[255]},"Value":"on/enable"}
[2023-08-14T15:34:27.912Z] Node[128]: [COMMAND_CLASS_SWITCH_MULTILEVEL] {"Value (Raw)":{"type":"Buffer","data":[87]},"Value":87}
[2023-08-14T15:34:28.624Z] Node[130]: [COMMAND_CLASS_SWITCH_BINARY] {"Value (Raw)":{"type":"Buffer","data":[255]},"Value":"on/enable"}
[2023-08-14T15:34:28.630Z] Node[130]: [COMMAND_CLASS_SWITCH_BINARY] {"Value (Raw)":{"type":"Buffer","data":[255]},"Value":"on/enable"}
[2023-08-14T15:34:28.811Z] Node[130]: [COMMAND_CLASS_SWITCH_BINARY] {"Value (Raw)":{"type":"Buffer","data":[255]},"Value":"on/enable"}
[2023-08-14T15:34:28.874Z] Node[130]: [COMMAND_CLASS_SWITCH_BINARY] {"Value (Raw)":{"type":"Buffer","data":[255]},"Value":"on/enable"}
[2023-08-14T15:34:28.896Z] Node[130]: [COMMAND_CLASS_SWITCH_BINARY] {"Value (Raw)":{"type":"Buffer","data":[255]},"Value":"on/enable"}
[2023-08-14T15:34:30.025Z] Node[128]: [COMMAND_CLASS_SWITCH_MULTILEVEL] {"Value (Raw)":{"type":"Buffer","data":[87]},"Value":87}
[2023-08-14T15:34:30.029Z] Node[128]: [COMMAND_CLASS_SWITCH_MULTILEVEL] {"Value (Raw)":{"type":"Buffer","data":[87]},"Value":87}
[2023-08-14T15:34:30.032Z] Node[128]: [COMMAND_CLASS_SWITCH_MULTILEVEL] {"Value (Raw)":{"type":"Buffer","data":[87]},"Value":87}

If not, anyone else know how to stop this traffic swamping the z-wave network.?

(Because of this traffic, the other z-wave devices are failing to respond/add, etc.)

Hi Daniel. I’ve just recently had a go at this. I think it is possible to put the blind in Ln mode from the remote, which I did (it’s listed as 2 on my controller). But after that some whacky stuff has been happening. Please let.me.kniw if you got anywhere.

Hi @JonE ,
Did you manage to get the ZRH12 working as secondary controller? I have 2 AMZ solar sunscreens and 1 ZRH12 remote. I removed 1 screen from the remote and connected the screen to Homey, working perfectly.
However, I cannot manage to add the remote as secondary controller. Just as you I get stuck at ‘add device to network’ button on the primary controller.

@Martijn_C did you press the P button when adding the ZRH12 as secondary controller? I tried everything, also pressing the P button, but the remote just times out every time.

@Joram no, unfortunately I haven’t got it to work either. To be honest, after a series of attempts back then (around the time that I wrote this topic here) I gave up, although I have the feeling it must have been possible somehow. So if you find out, PLEASE let me know! :slight_smile:

1 Like

Maybe it would work to add the ZRH12 as primary controller. When connecting to the homey, you can allow a secondary connection on the ZRH12. I will try that next.

Any update on this. I have a ZWS230 which now works fine, but it is very chatty and still floods the network with alot of traffic.

No. Never had any response from any of numerous attempts to contact the developer on any channel. I guess Fakro is just not interested in customers after selling the devices. Velux or Keylite for me next time.

Do you perhaps have a solution for operating my Keylite roof windows?