[App] Eurotronic Technology App (Stable: v3.0.1)

Tried everything but no luck adding the devices. Must be a device problem also Athom support could not found a problem w my Homey. What I figured out is that the device should countdown when including (from 120 down) it does just stay on 120???

So I received a z-wave movement sensor and it connected without any problems! Still no luck with my Spirit’s… Can anybody let me know if the Spirit should countdown anyway when including? Mine stays at 120.

It should indeed be counting down on the screen during inclusion, not necessarily until it reaches 0, it will stop counting when it is done and show you that you can put it on the valve then you can press the boost button to finish the inclusion

Ok, then my 2 Spirit’s might be defect as they both don’t countdown and stay on 120.

I have a spitit zwave device but i cant connect it to homey, most of te times homey says “Er is geen zwave apparaat gevonden” or it says “status already_added” but there is no unknown device in de zwave developpers overview. please i can use some advise. THX!

There is a very nice topic for this.

And this topic

@Caseda & @Rocodamelshekima Again you both are te Homey heroes of the day!!! THX!

Hold while unpowered and
insert batteries
Allows factory reset of the Spirit Z-Wave Plus.

Now it connects direct!!!


1 Like

No response from Eurotronic…
I’m the mean time I’ve purchased 2 Dansfoss thermostats and they were added without any problems. So basically I’m stuck with 2 Spirits in the shelve…

I installed the Beta months ago. Now I have to go to the stable version. Is it necessary to exclude all thermostats from Homey and ZWave before updating the app and insert them again after updating?

Not sure why you’d want to go back to stable, but going back to stable does delete all settings and devices, so you’ll need to re-pair devices and recreate flows then anyway, with or without excluding before.

I assumed the settings are also deleted if I install another beta.
So updating with a new beta will keep all settings?

I have 2.0.6 installed now and can’t update to 2.1.0 because of Homeys version (version 3 needed). I hoped 2.0.7 would improve the Z-Wave stability. At the moment, some thermostats are not reachable sometimes.

An app update will 99% of the time not improve z-wave stability, only an Homey update can do this, this isn’t just for the eurotronic app, but for all z-wave apps.

Your issue is more likely a range issue, Homey’s range is small when the mesh network isn’t stable/big enough.

As for installing another beta (staying in beta) update, yes that will keep all your devices and settings.

Thanks for your answer. Then I will keep the beta.
I just hoped the meshdriver update in 2.0.7 could bring some improvements.
I’m using a z-wave repeater and most times all is fine. But sometimes one or two thermostats (sometimes a thermostat next to the repeater) are offline. I get a error message (no response or no acknowledge) in Homey app and HomeyHeatingScheduler can’t set the temperature.
When I open the Z-Wave list on the developer page in this situation and send a test message they come online again. Like you said it seems to be a Homey problem.

Just a question. How do I completly shutdown the waterflow. Als if hell frezes over? Does this Work?

not sure if the measured temperature of the valve itself will still cap it at 7 degrees and then just open again to stop freezing or not, but that indeed will close the valve completely.

Ok, and is it neccecary to first set it in manuaal modus?

that isn’t necessary, when you activate the manual flow card it will also set the thermostat mode to manual if it isn’t already.

1 Like

For those who didn’t read (like me) and ordered some of these valves and get surprised when they don’t fit… Fix it in 10 minutes with your own 3D Printer.

Check out this adapter ring (M28 > M30) + extension pin


Does anyone use the Spirit thermostates with the app “Homey Heating Planer” (by Markus Kling)?
I set up a rudimentary schedule changing the temperature from 21 und 23 degress every morning.
Nearly anyone of those two changings (from 21 to 23 or - when it’s time from 23 to 21) dont work.
Sometime it changes to 23 but dont change back after the time – or it don’t changes from 21 to 23.

I’m not sure if this is a problem from the app “Heating Planer” or from the Eurotronic app, because sometimes even manual changes to a thermostat won’t work and I get a timeout error in the homey app :frowning:

Any ideas? Maybe I need to make some changes in the advanced mode of the thermostates?

Sadly I dont have a screenshot yet - I’ll attach it, as soon as possible.