[App] Eurotronic Technology App (Stable: v3.0.1)

I have 2 issues

  1. When external temperature sensor is used, the thermostat heats and heats without controlling against the target temperature

  2. When using the Economic mode, the correct temperature is sent to the thermostat but not displayed in the app! The same fore mode OFF!

Homey v2.5.2
App v2.0.7

  1. Depends on what external temperature is in memory/you are sending of course, I have no further control over the valve, it takes care of opening the valve more or less on its own, this has not changed at all since the start, make sure you are sending proper temperatures/configured your direct association properly.

  2. The target_temperature capability will always show the comfort mode temperature, not any of the other mode’s temperature, this is by design, and will not change, as people might see it as also changing the economic temperature with it when in that mode, which is not possible.
    You can see (and set) the economic temperature in your advanced settings.

Concerning point 2 I have to carefully say:
Hmmm, I don’t think so.
Correct me if I’m wrong but I set up mine as follows:

Valve using external temperature sensor.
Valve using external target temp as target temp.

WHEN Temp sensor X changed temp THEN send room temp to Valve.
WHEN Target Temp of Heating changes (mine is a Tado) THEN set temperature on valve to that target temperature of heating.

The valves remain in comfortable mode all the time but the shown target temp is automatically the target temp of the heating (tado).

He’s talking about the temperature shown in the GUI when it is in economic mode, not sure what you are talking about, but you aren’t talking about economic temperature it seems like, which isn’t shown in the target temperature of the GUI, your way of working with the app is entirely different then his point.

Hi!! Received my Spirit devices today. I tried to connect them to Homey via the app and general zwave but it doesn’t work… Homey is on version 2.5.2 and therefore not allowed to install the beta version of the app. What am I doing wrong?

And you are sure you have the z-wave version and not the zigbee (not supported) version?
if so, what doesn’t work, if it doesn’t include try resetting the device.

Yes, it’s a zwave-plus version. I pressed the boost button and the light starts blinking and device is in ‘Inc’ mode. After some time I get messenger that no z-wave device could be found. I placed the device next to my Homey.

I tried the factory reset this morning (holding boost button and re-insert batteries). Reset works but then again the device remains in inclusion mode. I have used following steps while trying to pair the device:
-Insert batteries
-Add device in Homey (Eurotronic Spirit Z-Wave)
-Press Boost button (lcd screens shows Inc)
-Then nothing happens and it times out (no Z-wave device found)

-If I press the boost button 2nd time I get 120 on the LCD, but also nothing happens

Then the thermostatic is probably just broken, if other z-wave devices still work.
You could try to take the power of Homey for 10+ minutes and see if that fixes it, if not then it is your thermostatic.

I have 2 devices (both Eurotronic Spirit) and both don’t work out of the box. Further no other z-wave devices. I’ll try the Homey reset to see if that works. It would be strange if 2 new devices both don’t work.

What was the distance between homey and Spirit during the Inclusion?

If a ptp (pull the plug) doesn’t work, then it might be your Homey, either the wrong frequency (hardware), wrong zwave region (software, in the settings changeable), or bad z-wave chip, for 1 and 3 you’ll need to contact Athom

Distance Homey and Spirit was less than 1 cm

Zwave region is on Europe (HW region) and EU (SW region)

Did u try to remove the device from Homey before adding it?
In the developer tools, remove any node and then put ur device in inclusion mode?

I can’t remove the device because it is not there. I can’t add it so neither can remove it. Or do you mean something else?
I tried the unplug of the homey for more than 10 min but no luck… homey is brand new (1 week) and the 2 Spirits are also brand new. Must be a hardware problem in the Homey I guess!?

Remove any node and put ur device in inclusion mode.

Yep tried it and I get the message network request failed

I have send a contact request to Athom. Maybe one more thing to try; My Homey is powered via a USB port (not the Homey power plug), can it be that this does not deliver sufficient power for Z-wave?

Just make sure the power is at least 2.0 A !