[APP][Cloud & Pro] SwitchBot (Release 1.1.43, Test 1.1.48)

It almost never works when you log in with google / facebook or such.
Create a so called email login, and try again.

I guess I’ll try to change my email, switchbot isn’t making it easy, thank you

Hoi Adrian,

Thanks for your response but i have tried what you advice me and it’s not working… i get the following message (see screenshot) what i am doing wrong.

At what point does that error appear?

When i click on the button curtain close

Have you tried restarting the app?

Also i restart the app

What i also have done is the app switchbot removed and i install the app again but i have the same problems

An issue (with solution) if it helps others. Then a question …

Issue and Solution: I couldn’t get Homey to connect to my SwitchBot Hub due to my credentials always being rejected as “Incorrect username or password.” I tried everything, so contacted SwitchBot support. They answered and, turns out, the login is case sensitive. I had unintentionally capitalized the first letter of my email, so it was always rejecting me. Using case sensitive entry solved it.

Question:
Is there a way to get the SwitchBot Hub itself to appear in Homey so that I can use its temperature reading as part of a flow? (i.e. if Hub at X-temp, start Airco flow)
I have not enabled the Matter modes out of caution for their Beta state, but maybe this is where the solution is located?

Thank you!

I think the case sensitive issues is reported higher up, but there is a lot to look through to find it.

The hub temperature can be added using the normal temperature and humidity (hub) device.

hi Adrian. Have you already an idea what the problem of this is

It looks like a server error.
At what point does the message appear.?
Could you send the Diagnostics log.

Have you seen my message?

It looks like you have sent the Detected log instead of the Log log

when i make a diagnostic log i got this

That looks like a Homey Diagnostics Log.
If you open the app settings and tap on the Log tab, you should see something like the image I posted.

Hope this the right one

That’s the one.

Unfortunately, I’m seeing a lot of error 190 messages lately, since Switchbot moved their servers. I’m not sure if they have configuration issues or just reliability issues, but they are getting annoying.

Thanks man for your answer. I should not look for a problem with me, but at Switchbot. Do you contact Switchbot or do I have to wait for an update of the app? Thank’s

Hello everyone

I bought the Switchbot lock and door sensor, I am trying to make the door lock after the door closes, no matter what I put the door won’t lock after closing the door, I checked the switchbot app to make the automation but doesnt have the option to lock under “then”.