Alternative ways to use Echo devices for sound output

As the Alexa app is broken for quite some time and it looks not too likely that it will get fixed anytime soon, I’m eager to find other ways to use Echo devices as speakers for notifications.

What I have:
1x Echo 1. gen
2x Echo dot 3. gen

What I would like to do:
Use them as speakers when a certain flow triggers an action to make them say something.

Is there any way to achieve that?

Please test again with the test version of Alexa App.
The new version stays online much longer. My Echos are useable since installing this version.

1 Like

Will test it. Thanks for the info!

1st impression: It disconnected just half an hour after upgrading to the test version. But I did not reconnect after updating because it appeared to be still connected and first tests also indicated that.
So, now I have reconnected yet again with the test version and wait and see what happens.

So, after less than one day the connection collapsed yet again.
This update does not solve the problem.

Meaning: Back to square one. Is there any way to use the echos as speakers for notifications?

My devices stop working after a day or two but the Alexa app is still connected.

With test version 3.7.101 the deactivation and activation tip should work. At least in my case.

Test it again, please.

Requirement regarding notifications => the only way = Homey’s Alexa App

How do you send notifications to an Alexa device via Homey’s Alexa app? I thought it is only useful if you want Alexa to run Homey …

Did you read the card options of the Homeys=Jamies Alexa App?

Or do we have a missunderstanding?

Ah, you mean the app that is not working for me.
I thought you meant the Homey skill at Alexa and I wondered how I could utilize that.

So, after the devices became unavailable again, I tried to disable and re-enable it. But this does not change anything: The devices are still shown as unavailable.

That is really unfortunate. Maybe one last attempt from my side:


a) Do your devices stay connected and just stop responding? you can check this in the Alexa app. If there is a button with “Click to diconnect” visible, then this is the case and you are still connected.


b) If red triangles are displayed in the devices, then the Alexa app should have lost the connection.

If a) is the case, you are probably one of the users who still have the problem. Bad luck.

In b) I would delete the existing devices and create new ones with the test version.

Good luck!

My case is b.
I tried what you suggested (deleted the devices and re-created them with the test version) - and they are gone again (red triangles, not responding).

Does the “Reconnect Button” work? At least for a few hours?


eu-Server: yes
2fa: temporarily disabeled (without any noticable effect)

What do you mean with “Reconnect Button”? Disabling the app and re-enabling it again?
No, that does not help. The devices stay disconnected.

The only working way to (temporarily) regain access is by re-authenticating.

Go to Alexa App Configuration.

There you should see the connect + reconnect button:

In the configuration I see only the configuration dialog, almost as if nothing had ever been configured before.
I can run through the dialog (provide my password again which will fetch a new token), and yes, this will re-enable my devices temporarily.

and you are using v3.7.101?

1 Like

I thought so.
Now, as I checked I’m (back?) at v3.5.101.

So, I have removed Alexa completely and started with 3.7.101 again. Added devices again.
Will take a while to see what happens.

So, looks like this did the trick.

The devices work now for more than a day in a row, which they never did yet.
Thank you!


In addition this is also my experience, but I recognized the point mentioned before after a few days:

If this should occur you can use the this flow to maintain the response based on the on/off trick. In my case I let the flow run with a frequency of 4 hours. Since then no more problems.

1 Like