433 weather sensor not picking up

I’m trying to read a Cresta 433 wireless Thermo/hygro with the wireless weather sensor app. Still no success. The app reads another Oregon scientific without problems, and the Cresta also worked with my Homewizard. But no Cresta direct via the wireless weather sensor. Any ideas.

Probably connection problem due to range. The 433 range of Homey is worse than that from the HW.
Are u sure it is a 433 and not an 868 type?

I think a 433. It’s a simple Thermo/hygro. Only the name Cresta on it, no modelnumber. Inside a channel 1-2-3 switch.
The thermometer is now approx 2 m from the Homey.

1-2-3 should indeed indicate a 433 model. Try some new fresh batteries, restart the weather sensor app and give the app the time to discover it (can take up to 10 minutes), depending on how many brands to discover you selected (less is faster and creates less overhead).

I wonders if and how you got it working after all, I have the same.
type is Cresta TX210 with fresh batteries.
close to the homey pro.
t’s not discovering it, tried a few days.

That’s a long time ago. I think I deleted them. I have now two 433/868 sensors, connected to a Homewizard weather station and Homewizard. The homewizard is connected to Homey. No issues.
I also have several Xiaomi temperature sensors for indoor use.