ZWave Route

He everyone!

My zwave network is unreliable and i’m struggling to get it to work better.

What i don’t understand is the route my devices choose. I have a device 8m and (except for the in line of sight from Homey. But the route it shows is from the ground floor, to the first, to the second, back to the first, and then a device further away on the ground floor and then the device it self. It looks like it’s trying the most complicated route available :slight_smile:

I’ve tried removing and re-adding devices, healing the devices and restarting Homey. But nothing seems to fix this. Is there a way to force a route, or anything that i could try to fix this?


Did try the heal button? Click on the 3 dots.

Hi Roy,

Thanks. Yes i did. But it keeps choosing absurd routes. Even removing and re-adding the device doesn’t solve it.

But the mean question, does the devices work ok.

The Z-Wave routes are, at least according to our understanding, not or not always logically structured. For this reason, it does not have to be an error.
What exactly does “unreliable” mean?

Are the devices “secure” or “unsecure” included?
It is recommended to include the devices “unsecure”. As far as I know, this reduces the amount of data significantly. The result is (noticeably) faster response times.

Have you checked the Tx Error value in Developer?

With unreliable i mean they sometimes do not respond and home gives a timeout. When I then toggle it manually homey immediately shows the change, so it the message from the switches do get trough to Homey.

I do get a lot of tx errors but would’t those be related to the complex route?

The devices are showing:

zw_secure: “x”

not sure if the x means, secure or insecure.

Not really, I don’t think so.
But you have an “Unknown Node” (ID16) over which is routed. This device is either a powered device that has been without power for a longer time, or this device is not properly included. I would re-include this device.

This means insecure.
“Secure” included devices can also be identified in the Z-Wave overview in Developer. If the devices are “secure” included, then in the column “Flags” appears “secure”.

Btw., are these all your Z-Wave devices in the list? Or do you have more devices that are not shown in the screenshot?
In the list there are 7 repaters, but if they are installed far away from each other in the house, then there might be connection problems. In addition, there are other possible factors in the house that can interfere the connection.

From my experience with Homey that I have currently 35 zwave 40 zigbee and 15 wifi devices connected and controlled:

  • Antenna mod did a significant improvement in direct zwave routing of devices to Homey as you can see in my screenshot bellow.
  • Despite of antenna mod, there are still some devices that “like to route a lot” and they are not far away from Homey (some Fibaro Roller2 mostly and battery remotes). But they do work without problems.
  • Unsecure inclusion of zwave devices made a significant improvement on overall zwave performance in terms of response.
  • I have no tx errors, only some erros on 2 devices that are not always powered which is normal.

1 Like

I have never seen anything like this with Z-Wave. It looks like Zigbee “Mesh” with Homey FW 4.2… :joy:
It seems to work well, but the purpose of Z-Wave technology is in fact something else.

This is what my Z-Wave mesh looks like. So multiple hops are not a problem. Maximum 4 hops are supported.

I can assure you that its zwave :wink:. I was also surprised that routing was such “eliminated”. It seems, once Homey has got good transmition of signal (antenna mod), it prefers direct connection in case of zwave. Zigbee routing on V5 is using routing for all battery devices and looks different:

1 Like

Wondering is there some way to select use of unsecure connection? While pairing devices have not seen possibility to choose.

Instead of selecting the exact device in the inclusion process, use a Fibaro device from the Walli series, e.g. Walli Switch. I have heard that this also works with all Qubino devices, but I have not tried it myself yet.

Don’t worry, based on different IDs (manufacturer, device type, device) the device will still be included correctly.

After release of Homey firmware v7.x the “Walli method” for including devices unsecure doesn’t work anymore.
Please follow this thread:

Where can I find Z-Wave route?

Developer → Z-Wave

Thank you for that!