What I need is support for the following device : ZDB5100 It’s a Four bottom Dimmer/Switch from Logic Home. I installed the “Logic Home Control” app, but the device zdb5100 is not supported. I would like to contact the group writing the software for the LogicHome devices.? Under the support page “Feature request for Homey” there is a link to a request form but the link seems to be wrong : https://goo.gl/forms/WyLpQodlV9jtghPk1 can anyone help?

@TedTolboom ^^

Super thanks!

@Svenning thanks for asking.

At this moment the Logic Home control / Logic Group app is not being further developed by me.

Through a Danish friend I learned that Logic Group is no longer further investing into Homey as automation platform. Without access to these devices, it is not possible to add support for them; due to the huge amount of different options embedded in the devices firmware.

Please contact Logic Group directly and request for support to further develop this app and add support for these new devices. They know how to contact me.

Just dropped Logic Group an email right now.

Did you any contact them yourself, @Svenning?

Yes i contacted Them back in oktober and they answered:
Hej Svenning
Den Logic Home Control app der er tilgængelig, er ikke udviklet af os.
Det er Ted Tolboom, som har stået for udviklingen (i tæt kontakt med os).
En ønsket udvidelse til denne app, skal aftales direkte med ham.
Med venlig hilsen / Best regards
Allan Lytken

Translated is means that any new development must be agreed with Ted…

And same reply now:

Hi Kenneth, We are not responsible for the implementation of the Homey driver. We don't have the resources to implement drivers to all Controllers yet. The latest implementation of our ZHC5010 is made by Ted Tolboom. Maybe you can talk to him about implementing Matrix DB in the App to Homey.

@TedTolboom - What’s your view on updating the Homey app? Is it something you could be interested in or isn’t this interesting for you anymore?

@svenning and @KennethJ thanks for reaching out.

The honest answer is that I really like the Logic Group devices from an engineering perspective providing the extensive amount of options, that create almost unlimited options for the end-user.

But that also creates the downside for the app developer implementing and debugging all options, and the corresponding driver logic, to ensure the right end-user experience / expectations.

Based on the comparable but also different ZHC5002, it will still require me a substantial amount of time (at least 40 hours) of work to build and debug the new driver for the ZDB5100. Not accounting for the other Matrix devices.
Considering the private time available, I can’t make a commitment to add support for these devices.

Hi! Any news to this topic? Still no support for the ZDB5100?

Not to my knowledge…

Greetings @Svenning, @F_Foldager,@KennethJ !
If still relevant you are welcome to try

Have a great day !

Looks good @Arturas_Taskauskas, thanks for adding it :slight_smile:
though i don’t have any of the matrix devices, I’m interested in the Z-Wave Socket Outlet that they have underway, so hoping you will update when time comes :wink:

:warning: SOLVED :warning:
Moved Homey real close to the new switches. Have to pair directly to Homey to begin with. Required a few PTP, but it worked.

Hi Arturas. I have just bought and installed two ZDB5100 but cannot add them to Homey. When I press the little switch the #1 button flashes but nothing else happens. I thought it was my z wave network and bought two Fibaro plugs to extend the network. They work just fine. I have even put one of the plugs right under the ZDB5100 switch (please see image). What to do?

Har I oplevet noget lignende/erfaringer at dele? @MVester @Svenning @KennethJ @F_Foldager

Works fine at my house. I have two zdb5100 installed.

Thx. Got it fixed. What have you done with the switches? I just assigned button 2 for playing a radio channel via Sonos in the bathroom.

Have the exact same problem: Tried to add my ZDB5100 to Homey but no reaction.

Edit: Now I moved the switch within 1 meter of Homey and it worked like a charm.

Next step is to set up the buttons and background LEDs.

Have you got the full functionality of the switch: single-, double-, triple and long-press for all four buttons?

Haven’t used triple and long press. But double works just fine. I also use the LEDs to show alerts, eg. Open Windows=red, washing machine started=green, towel heater on=red etc. And buttons to turn on Sonos etc.

I got it and got most other functionality to work, but the LED-lights.
I can set the RGB values alright, but it does not show on the actual switch.

Any suggestions and/or examples will be appreciated since I seem to be stuck.

[UPDATE] Think I cracked it, just needed to vent my frustration and get back into “stubborn mode”. I think I will be able to get the LED’s to work now. :shushing_face:

Good to know. You should understand that LED lights and activation of each button is two different actions. You should also understand that all changes/amendments should be made in the advanced features of the main switch device and not the individual buttons. Hope it works.

1 Like