Z-Wave devices unreachable, but do work

I’ve got a few Z-Wave devices. They all seem to work but some have Flags with either ‘unreachable’ or ‘secure, unreachable’.

Now this is not true because they work, and therefor must be reachable, but what does that mean? Is it something to worry about of should I adjust something?

When I send a test frame it also says it is not reachable. But a basic off / on works.

For clarification:

The devices probably send the “ok I received your signal” too late, or homey processing them too late, or not receiving them at all.

If that is (too late) for 3 times it will sign the device as unreachable, or from 1 time of the “test” button. (this is only for mains powered devices)

Might be a range issue, or something else drastically lowering the range capabilities of those devices.

The basic on/off from the dev pages doesn’t wait for the ok signal back, only for if the zwave chip inside homey gives it the “signal send” state.

For with the ‘wasmachine’ I can imagine it’s out of range, because that’s on the 2nd floor and homey is on the groundfloor, in the 1th floor there is only one Z-wave router. But it does report back power consumption so all flows do work.

For the ‘heater 2’, I can’t imagine its a range issue, I think there is a max of 5 mtr between the heater and the Homey. The Quooker is in between of them, but doesn’t get routed through. Same goes for the PlayStation 4, it’s in a line of sight and I think it’s like 6 mtrs away.

Any advise? Maybe resetting the Z-wave network?

Now there are a lot of different routes… But Heater 2 doesn’t respond anymore. Maybe there is a signal problem, but it is so close.

I have the same problem. Some devices turn unreachable all the time but work just fine.
Have tried to heal those devices but it keeps the same route.
Will follow this thread.

I have also the same problem!
I have also tried to heal those devices but it keeps the same route and 4 devices are still unreachable and do not work :frowning:

I also use homee and an Raspberry Pi with Razberry Z-Wave-Modul -> If I include the same Z-Wave devices at the same position both (homee and Raspi -> same position like homey) work without any problems.

Has anyone an idea to expand the z-wave range without installation of external antennas?

Unfortunately i’ve not managed to get this sorted. Finally i’ve bought the new external antennas and added them. Now it works, but i’ve still got some devices saying their not responsive. They however do work flawlessly. I have to do some resoldering, because i’ve made a mess of it. But i guess that’ll be somewhere in autumn.

When I use the Z-wave test command, the response is immediate “Host X is reachable” and in the table the “unreachable” disappears.
So it is not a problem with the Z-wave network.

To your Homey. How did you do that?


The search function still works excellent… :innocent:

Yes it does. But none tells how to connect external antennes to your Homey.
So you opened your Homey?

Are you serious? Did you even bother to click on the first link result from the search? :hushed:

My sorting was different from yours. I have red that topic long time before. I asked @Martijn_Hoogenbosch because the sentence “ Finally i’ve bought the new external antennas and added them” looks to suggest adding external antenna’s is a new Homey product and just a peace of cake. Thus not. Carefully reading again the word soldering is mentioned.

Well, you are also responding to a 4 year old topic, so “new” is kinda relative then.

Your right, some times I am lost in this forum, sorry.

1 Like