Vraagje door newbie over Somfy IO Connexoon

Hoi allen, ik ben een complete newbie op de Homey Pro (net binnen :grinning:) en wil graag een somfy screen via hoemy aansturen. Ik ben in bezit van een (oudere) connexoon (geen rts maar alleen somfy-io) die ik met de tahoma-app prima ook buitenshuis kan aansturen. Het lukt mij echter niet om hem te koppelen in Homey.
Heb de Tahamo-App gedownload maar na inloggen ziet deze geen apparaten.
Iemand enig idee?

Heb je hier al gekeken? https://community.homey.app/t/app-cloud-pro-somfy-tahoma-connexoon-v4-0-37-test-v4-0-39/35206
Als je naar de Somfy app pagina gaat van Homey staat er ook een link naar het desbetreffende forum.
Dit geldt ook voor andere apps.

1 Like

Hoi Mike,
Dankjewel voor je reactie.

Ik heb de test-app geïnstalleerd en de somfy connexoon op developer gezet. Helaas kan ik dan nog steeds geen apparaat vinden.

En je hebt dit ook gedaan zoals op het topic staat?

Local Access

Tahoma and Connexoon now support local access when using a Homey Pro. To enable this you need to switch on the Developer mode in you Somfy account:
First connect to the Somfy website and navigate to the :man: My Account menu.
Find the different available options for your TaHoma box and activate Developer Mode .
Once developer mode is activated, your Tahoma box will start sending mDNS data advertising it’s IP address. The app will detect that and setup a local connection automatically, so you don’t need to do anything on your Homey Pro to use it. All you existing devices that are supported by direct connection will start using the local access to Tahoma.

Zo ja, misschien je vraag ook even in dat topic stellen.

1 Like

Ik heb het inderdaad zo gedaan.
Er staat “The app will detect that and setup a local connection automatically, so you don’t need to do anything on your Homey Pro to use it.”
Waar zou ik dat dan moeten kunnen zien? Toch gewoon weer in die Tahoma Test App?

Can you send me the device log from the app settings page?

Hi Adrian,

Thx for your reply.
To do this, Do I need to install the test-version of the App?

PS: I have the ‘Screen Ambiance’ outdor sunscreen that works with the Tahoma App.

No, all version have that option. Just open the Homey app and go to More - Settings - Somfy Tahoma & Connexoon and then select the Device Log tab. Then tap on Get Log and when the list is full tap on Send Log. That will send the list of devices that you have so Ii can either let you know what Homey device to use or add support if it a new device to the app.

Ok, just did that.

PS, i also sent the information log. There is said it found aMDNS local bridge.

“time”: “2023-06-28T11:48:44.005Z”,
“elapsed”: 0.161,
“source”: “mDNS Found a local bridge”,
“data”: {
“pin”: “####-####-####”,
“address”: “”,
“port”: 8443,
“api_version”: “1”,
“fw_version”: “2023.1.4-12”

So, you need to use the “Exterior blind (io)” / “Verticale buitenzonwering (io)” device to add your blind.

1 Like

Great ! That did the job. Thank you !
Works perfectly now.
Can you tell me how you did find this would be the device so I can learn :wink:

I look up the Controllable name parameter and match it to a device in the app, so not easy for users to do.
I’m still trying to find a better solution.

1 Like

I get a similar error as Ger-van Lierop with the Homey Pro 2023 and Somfy Tahoma. (in Developer Mode)

The TaHoma & Connexoon App for Homey is installed. User name and password are correctly filled in.

When I add a new device I get a error messages:
(example: Verticale buitenzonwering (io) )

“connect econnrefused”

the information log:
“time”: “2023-08-06T10:37:44.005Z”,
“elapsed”: 0.161,
“source”: “mDNS Found a local bridge”,
“data”: {
“pin”: “####-####-####”,
“address”: “”,
“port”: 8443,
“api_version”: “1”,
“fw_version”: “2023.3.4-5”

How can I solve this error?

Could you try restarting the Somfy bridge and the Homey app to see if that helps.

I restarted the Somfy TaHoma Box and the Homey app but still get the same error when I add a new device:
“connect econnrefused”

(only the IP adress is changed)

Hmm, I’ve not seen the connection refused like that before.
Can you open the local tokens tab, thenn tap on Get Tokens to see if any tokens have be generated.

“label”: “Homey token 64a800c609af3e73746a0b83”,
“gatewayId”: “1208-0386-5922”,
“gatewayCreationTime”: 1691320237000,
“uuid”: “128dc469-e672-4aca-a2fb-a29dd62efa78”,
“scope”: “devmode”

To get the token it must have logged into your account OK but that is done over the internet, but I have no idea why the box would refuse the connection.
I will check it out on the Somfy API repo to see if anyone can give me an answer.