Variable values not showing up in flow tags


I have a HomeyScript with only one line of code:

tag("AvgPrice", "Test");

When running the script, it creates a flow tag but the value is always “-” when trying to reach it from the advanced flow.

Any ideas why?

I have tried with both strings and numerical values but both of them just shows up as a “-”. (See to the right in the attached image)

Skärmavbild 2024-01-12 kl. 16.55.23

better use this format: await tag('neerslag', data);

Tried it, but that did unfortunately not help.

await tag('Test123', 123);

Still just shows up as a “-”. Weird thing is that it marks the flow tag green if I enter a string, and blue if I enter an integer.

Are you really sure it is -? and not just a never implemented feature in the web app? (hint hint)

How does your flow look like? Please share if you want help.

Like Caseda hinted (I think), just use the tag in a timeline notification card → THEN you’ll see its value.
Not in the selection list.

That’s b/c green is used with string tags, and blue for num tags

Here’s a screenshot of the flow. All of the HomeyScript values are “-” but displays fine from other apps.

Like I proposed, send the tag with a notification card. Does it send a “-”?

The flow must have RUN at least once, before the value is visible.
( this is done on my HomeyPro(early2016) )

1 Like

Just like JPe4619 said, the solution was to run the script once in the advanced flow and then the valued showed up!

Thanks alot!

1 Like