SSH Experiment, Connection refused

Hey guy, i’ve just bought the Homey Pro (Early 2023).
I want to try out the SSH experiment. But after enabling the feature, port 22 never seem to be open/available, whatever i do nothing is listening on port 22 on the homey.

How long is it supposed to take, before port 22 is available?

I tried disabling and reenabling the feature. Also tried resetting homey to default.
I am using the ethernet adapter to connect my homey to the network.

Anyone had such problems?

Homey Pro (Early 2023)


And this is not helping?

How long did you wait? Before taking other actions…

Homey needs to download the sandbox image. Does your Homey have a good internet connection?

These seem to be instructions for getting the homey cli tool installed inside of the container, i am not getting that far unfortunately :frowning:

Its been sitting now with the feature enabled since yesterday evening. I have a very good internet connection, so the speed should be fine, but i did experience something odd when i tried to setup the homey initially, it was stuck downloading the homey update, and an error message popped up repeatedly, complaining about something network related, but it flashed by too quick for me to see the exact message. Had to connect the homey to my pc to reset it and upgrade the firmware.

It does leave me wondering if the homey is somehow hindered in connecting to certain resources, however i am able to install other homey apps onto just fine though.

Okay, so not sure what changed, but tried turning off the feature again just now, and then on again, and somehow now it works!, so i’m wondering if the resources it had to download were somehow temporarily unavailable or something. Sadly it does not provide much feedback about what its doing.