PeHa PHC en Homey

Hi all,

We have a PeHa PHC domotics solution in our home which I want to control via Homey. It seems the only way is to use the specific urls for each action. This is an example of the url: “Http://<<IP-address:80/postEvent.html?action=input&STM=0&MOD=0&CHA=4&EVT=4”

So I’ve looked at the ‘Http request flowchart’ app, but I can’t seem to get it working as each chart requires a url in one field and the commands/attributes in another. I tried several options and googled quite a bit yesterday, but I’m still nog able to get it working.

Does anyone know which chart in the app I should use and how to ‘split’ the url in two sections?
(If I should use a different app, I’d appreciate you letting me know.)

Note: The url works perfectly fine when pasting in a browser: I can turn lights on and off by using the respective urls for those.

Thank you in advance!

I’m not sure if you want to split the url or if that’s just what the ‘Http request flowchart’ app requires, but why not simply use the native webhook function in Homey? If you choose a Logic action card, there’s a way to do http requests without splitting the url. You can even use tags to form your url if that is of any use to you.

Thank you Edwin, it sometimes seems to be that easy.
When trying to use the Logic webrequest option and then testing the flow, it comes back with an error stating:image

Any further thoughts?

Not really. What’s exactly the card properties? Any chance the url didn’t get in there properly? Your sample does show some strange things (not a real IP but I assume this is because you do not want to share that publicly). Is there anything in the other fields? I would imagine an empy body: {} but it doesn’t seem to require that with me.

I just replaced a robot vacuum that I used to control using webrequests, so I no longer have any real life samples working at home, but if I take your url and replace the ip with one of my own I do not het any errors (though my NAS problay has no clue what to do with the request :slight_smile:).

I’ve been playing around the past week quite a bit to get this flow working. After deleting and recreating the card for the second time, I now don’t get the error anymore. I’m in the blind what I’ve done differently (as I don’t think I have done anything different), but at least the error is gone.

However, it’s still not working. See below a screenshot of the card as it exactly is. When testing the flow, (test button), it doesn’t work. If I then copy the url exactly as it’s in the card, and then paste it in a browser, it works just fine. Having the body empty (nothing in it) or “{}” in it, doesn’t matter. In the card it doesn’t work, in the browser it does work.

Any other ideas I should/could try? I appreciate any (crazy) ideas…

No ideas really. The only thing I can think of is that the test button might not work the same for webrequest. Have you tried putting a notification after the action and triggering it for real?
I’m not sure the “someone says” trigger works anymore though, i think newer Homey’s no longer support it and rely on Google integration. That is done though using a (virtual) switch and asking Google to turn that switch on.