Homey Community Forum

New Homey Wear OS app

So I’ve been using a Google WearOS smartwatch for quite some time. But as a big fan of my Homey I was missing the ability to use Homey connected devices via my smartwatch. So because the current Homey App does not provide its own WearOS functionality, I’ve created my own.

So I just want to let you guys know, that if you have a Google WearOS device, you can now use it to control your Homey.


Because how smartwatches are implemented the functionality of the app is quite limited. Basically you can only turn your devices on/off, play/pause or if its a button press. The devices lists only your favorite selected devices.

When you open the app for the first time, it notifies you that you have the login once via your mobile phone to your Athom Homey account. Once you do this, it gets your favorite devices and lists them on your WearOS device. Simply clicking on the devices switches its status, so play becomes pauze, on becomes off, etc.

Please note that it might take a couple of seconds for the app to get the latest status of your devices



Future additions

Besides controlling your favorite devices, I’m also looking into starting your favorite flows from your smartwatch. I’m hoping to add this functionality in the next couple of weeks.


Feedback is offcourse very much appreciate it. So if you have any feature requests please mention them on the Github page, so I can keep track of them.



I do not own a Wear OS watch anymore, but I think this app is very much welcome!
Great work, thx!

1 Like

First of all. Great that there is a app now.
I have a Asus Zenwatch 3 and i can not install the app.
It says it is not competible.

I like this development, finally an app on my watch. Gonna check it later this week on my fossil watch. Thanks already :slight_smile:

Hi, the app should be compatible to all modern WearOS version. Could you please share which specific WearOS version your Zenwatch is using and, maybe I can tweak the supported versions.

I own a Fitbit Ionic. I guess it won’t work with this wearable?
It would be really great if it does.
A suggestion for starting flows. It should be possible to create a virtual button to start a flow and put this in your favorite devices. Or did you allready tried this?

I’ve created the app for Google WearOS. So if you don’t have a WearOS smartwatch, unfortunately, it’s not going to work.

Your suggestion for starting flows is currently certainly possible. Mainly due to how Athom implemented devices and flows in Homey. However, I’m also currently developing the functionality to start flows without having to start it via a device. Similiar on how Athom currently allows starting flows via Android widgets.

I have a Zenwatch 3.
Android wear

Wow! This is great! Unfortunatly I have a Michael Kors Bradshaw Access… Google play says it’s not compatible? Can you maybe add support for more watches? :slight_smile:

1 Like

This is probably because I’ve only supported Android SDK 28/29. However, I’ve just released a new version of the app which adds support for Android SDK 25/26/27. This should ensure that all compatible WearOS 2.0 devices can use this app.

The app is currently under review and should be made available in the next couple of days. So check google play in a couple of days to check if you can install the app.

I’ve just updated the app which should add support. Please check google play in the next couple of days to see if you can install the app.

1 Like

I now can install the app on my watch.
But when a open the app it ask for permissions.
I o to my phone accept the permissions and press ALLOW.
After that the watch says that it fails.

At this moment a can not use the app beause of this fault.

Which permissions are exactly asked? Probably storage, there is a difference between Android versions on how to access internal file storage ( which is used by the app to save session tokens). With the latest Android version (Pie) there is no permission request whatsoever. So I need to determine what the difference is in Android versions to ensure what trigger the permission request.

Okay so apparently there was an issue in the released version of the app. Mainly due to the proguard rules in Android something went astray with handling the JSON from Athom which resulted in a NullPointerException every time you opened the app.

Due to me developing different versions on my smart watch this never occurred to me. I’ve just uploaded a new version which should resolve this entire issue. If you have any further issues, please let me know.

1 Like

Is this usefully app available for galaxy watch3? Where to find?

No, the Galaxy Watches use a Tizen OS, not Wear OS where this app is created for.

1 Like

Hey! Just installed your app on my fossil carlyle gen5.

After I started the app and log in I only get a cooler screen the it crash after a couples of seconds.

Any idé?

1 Like

I have the same problem with my Ticwatch Pro, the app crashes. Can’t get it working. Which is a pitty … :frowning:

1 Like

I had this problem to. Set your favorite devices to 1 device.
Start the app
Now restore your favorite devices.

Great fix man! Works now!